I'm trying to set up a Percona XtraDB cluster on two machines.. but i'm having a terrible time in getting the second machine up and running.

I have used this article as a reference, and while it seems to be almost working, there's probably something basic i'm missing.

Machines are as follows:

Node 1:
Node 2:

Both machines run Ubuntu 12.04 LTS.

The config file on Node 1 is similar to the article.

When i start this node using the above configuration, it works normally. I can log into it via command line and run the

mysql> SHOW status LIKE 'wsrep%';

command as it describes. Everything looks normal.

NOTE: Node 1 was previously a standard mySQL server, and has data already in the /var/lib/mysql folder. This has not affected it starting normally with the above configuration.

I then follow the steps outlined in the article regarding adding a new node. This seems to be where I run into issues.

I created the my.ini on Node 2 (, and used a configuration similar to the article.

When I try starting the service using service mysql start, it says it's started, yet I can no longer connect via the command line.

I tried changing the config file on Node 1 back to the original one, and then starting Node 2, but thats not working either.

I have captured the logs by simply starting mysql with the mysqld command on the command line, and here's the trimmed result (only stuff with errors):

130206 14:53:56 [ERROR] WSREP: Failed to read 'ready <addr>' from: wsrep_sst_xtrabackup --role 'joiner' --address 'ip_address' --auth 'root:password' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '14762'
        Read: '(null)'
130206 14:53:56 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role 'joiner' --address 'ip_address' --auth 'root:password' --datadir '/var/lib/mysql/' --defaults-file '/etc/mysql/my.cnf' --parent '14762': 2 (No such file or directory)
130206 14:53:56 [ERROR] WSREP: Failed to prepare for 'xtrabackup' SST. Unrecoverable.
130206 14:53:56 [ERROR] Aborting

Here's what Node 1 reports while Node 2 is connecting (Node 1 using the first config file - again trimmed)

130206 14:59:44 [ERROR] WSREP: failed to open gcomm backend connection: 110: failed to reach primary view: 110 (Connection timed out)
         at gcomm/src/pc.cpp:connect():139
130206 14:59:44 [ERROR] WSREP: gcs/src/gcs_core.c:gcs_core_open():195: Failed to open backend connection: -110 (Connection timed out)
130206 14:59:44 [ERROR] WSREP: gcs/src/gcs.c:gcs_open():1290: Failed to open channel 'percona_cluster' at 'gcomm://': -110 (Connection timed out)
130206 14:59:44 [ERROR] WSREP: gcs connect failed: Connection timed out
130206 14:59:44 [ERROR] WSREP: wsrep::connect() failed: 6
130206 14:59:44 [ERROR] Aborting

Node 2 reported similar.

If anyone can help me with what silly mistake I've made, it would be greatly appreciated.

(Sorry for the length of the post - I wanted to provide as much info as possible)

  • Providing as much info as possible is admirable, but can you please trim this down to the relevant information? This scrolls 5 pages down my screen, and that's not counting the fact that each block of data scrolls several lines -- asking a bunch of people to wade through this wall of text is really not conducive to getting good answers. – voretaq7 Feb 6 '13 at 16:40
  • Apologies for having it so long. I'm not sure what is and isn't relevant, hence me putting in so much detail. I've trimmed the hell out of it now! Thanks for the tips. – GoldieNZ Feb 6 '13 at 20:49

are you sure you have percona-xtrabackup and backup/replication scripts correctly installed? Reading your logs, it seems that the node can't locate wsrep_sst_xtrabackup, so it fails.

Also, it happened to me with wsrep_sst_rsync (https://bugs.launchpad.net/percona-xtradb-cluster/+bug/917265), maybe this is a similar issue.


  • Thanks. It does appear there was something wrong with my install. Installing on clean servers setup went fine, but using it as a dropin replacement I ran into errors. – GoldieNZ Feb 19 '13 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.