I first installed my ubuntu server (11.10 amd64) using lvm but not fully mastering the concept of it. I think that's partly what made the mess of partitions on my two disks (seems to me). I installed everything using grub2 from the start to boot my Ubuntu, which I updated later to Ubuntu Server 12.04, no problem.

Here is the situation:

  • As of today, I can't boot at all, stuck with no evolution at what seems to be just before the grub options (Edit: precision from Pavel A.);

  • I can boot using the server install liveCD with option Rescue a broken system;

  • I setup network access, but don't seem to have a /run folders (don't know if it's related but seemed abnormal in some forums);

  • The devices map I built is as follows:

    1. VGa contains sda1 [Linux partition], sda2, sda3 [/] and sda5(the latter seems the same as sda3, same descriptors)
    2. VGb contains sdc1, sdc2 [/boot] and sdc3 [/home]

    (the two do not have the same PE or LE, but I'd like ultimately to have everything in the same VG)

  • Last thing I did to the boot environment was to (cleanly) remove older kernels from the boot partition (236MB large, was 99% full);

  • I ran grub-install (after having mounted boot) but got various errors:

    • can't install on /dev/sdabecause core.imgwon't fit (first partion starts on 32)
    • output of grub-install on /dev/sdc exhibits error physical volume pv0 not found
    • I even tried to grub-install directly to /dev/sda5, apparently with no error, but with no success at boot either

I looked here [serverfault]: Grub2 reports physical volume pv0 not found when probing/installing
I looked here [Ubuntu forums]: SOLVED] Install kernel with liveCD & fix grub2
I looked here [Ubuntu help] : Fixing a Broken System
I looked here [ubuntu forums]: [SOLVED] 10.10 Maverick - Grub won't recognize my Windows partition

None of what I did changed anything to the stuck-boot-situation (I can't define it any better: it just hangs, for minutes and minutes and minutes).
I hope I've not left out any important detail.

I have no idea what to do anymore, especially if installing grub doesn't work. I've not lost any data, but as it was a production(-ish) server (i.e. entirely personal), I now strongly feel the need for mirrors (I already set backups but... on the server :p).

Anyway, if any of you geniuses had any idea or lead, that would be a great help.

Thank you


Edit: tail /var/log/syslog yields no output (blank), no new syslog is created that I can see

Edit2: I used the Boot Repair CD (Ubuntu Secure Remix version) and generated the following report on the state of my boot: http://paste.ubuntu.com/1620777

  • If you can get almost to the login prompt, then this has hardly anything to do with the kernel - Linux boots, some of the services/programs don't. It may be however that some of your services lucks certain kernel modules. I'd suggest you try to start your system (it won't), so you reboot, then enter recovery mode and have a look at /var/log/syslog that is left from a normal boot attempt. – Pavel A Feb 6 '13 at 14:41
  • Thanks for the quick answer Pavel. I should have been more precise but when I suspected it is a kernel or boot problem, it is because nothing is printed on-screen, nothing seems to be loaded nor done, there is just like a blinking cursor and that's it. That may be the source of the confusion. Thanks for notifying me. And when you say I reboot, I just press Ctrl+Alt+Suppr and that's it. And how do I enter recovery mode ? – Meeshkah Feb 6 '13 at 14:49
  • 1
    In that case I didn't understand you correctly. How is both of these possible: nothing is printed on-screen, nothing seems to be loaded nor done, there is just like a blinking cursor and that's it and stuck ... just before the tty login prompt? And what is the Suppr key? Do you mean Delete? If you cannot select recovery mode in console, you can still boot from a live CD to have a look at /var/log/syslog as you did before. – Pavel A Feb 6 '13 at 15:17
  • 1
    Regarding your Edit 2: are you sure the 'devices map' you describe in your post is accurate? What are for example sdb, sdd in that case? As shows the log, you also have GRUB2 installed on /dev/sdc. Does setting /dev/sdc prior to /dev/sda in boot device sequence solve the problem? – Pavel A Feb 9 '13 at 7:20
  • 2
    paste.ubuntu.com/1620777 paste not found ... – Brigo Apr 16 '13 at 19:06

Try to boot with a LiveCD, mount your Logical Volumes on a chroot and add the module lvm into the file /etc/default/grub:


followed by:

sudo update-grub

Make sure you have the lvm module into your initrd/initramfs.


Without the paste.bin, I'm going to provide a checklist because you got a weird setup going on and that is your Master Boot Record (MBR) is on a different drive than the /boot partition:

  • It isn't the BIOS ordering of hard drive boot startup (I suspected VGa and VGb being backward in BIOS)
    • your BIOS is checking VGa for the master boot record
  • Use fdisk to determine if /dev/sdc2 has boot flag marked for /boot partition

Then, I would do the following steps:

  • CD rescue disk booted
  • ensure all HD partitions are mounted under /mnt
mount /dev/sda3 /mnt
mkdir /mnt/boot
mount /dev/sdc2 /mnt/boot 
grub-install --boot-directory=/dev/sdc2 /dev/sda
grub-install --boot-directory=/mnt/boot /dev/sda

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.