I recently installed an ssl cert on my rackspace cloud server. Prior to installing it, my cron jobs were running fine.

When I ssh to my server and do a crontab -l,

I can see the jobs are still there:

*/5 * * * * /usr/bin/curl https://mydomain.com/crons/do_things.php

if I directly visit the file in my broswer it still works.

So I'm wondering if there is anything special I need to set up or change to have my cron job running again?

  • 1
    Have you tried running /usr/bin/curl https://mydomain.com/crons/do_things.php from the CLI? – ceejayoz Feb 6 '13 at 18:01
  • ahhh, ya, once I saw the warning it was an easy fix. I didn't know I could just do it from the cli, I thought it had to be in my cron file. – Rooster Feb 6 '13 at 18:07
up vote 2 down vote accepted

You can tell curl to ignore any ssl warning with -k option. Most likely it is the ssl warning which is stopping it from being executed automatically. The caveat is curl with perform "insecure" SSL connections and transfers.

/usr/bin/curl -k https://mydomain.com/crons/do_things.php

  • ya that did the trick thanks – Rooster Feb 6 '13 at 18:06

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.