0

I'm on a shared Windows host, and I have access to my DNS. I have changed the MX record to point to another domain. The email is not making there.

I followed this cookbook http://kb.webhosting.uk.com/how-to-use-and-set-external-mail-records-in-plesk-9-5/ I did remember to uncheck the "Activate Mail" as described on that page.

Let's say I'm trying to direct from foo.com to bar.com.

When I first set it up, I changed the foo.com MX record to mail.bar.com. (The UI at the foo shared host automagically adds a trailing ".") But, when that didn't work, I looked at the MX record of bar.com and saw that was simply bar.com. So, I tried that. Still no joy.

I'm sending email to ExistingAddress@foo.com, expecting to show up in the mailbox at ExistingAddress@bar.com

At bar.com, which is at Site5, it's unclear to me if the mail system there is not forwarding the emails to the ExistingAddress mailbox. I've tried enabling the Default Address entry. But, from the UI on that screen, it looks like it may require the domain name to match bar.com. Under the Email Forwarding section, it looks like I can only forward items that go to bar.com or one of the few subdomains I have set up.


From Site5 chat support:

In this case, since the domain is not added to the server, to my knowledge the current setup will not work. It may be best to do the following:

  1. Create an MX record on foo.com, for example: mail.foo.com
  2. Set the IP/A record of that to the server/account you have with us: xxx.xxx.xxx.xxx
  3. In SiteAdmin, park foo.com on bar.com
  4. In SiteAdmin, go to Email > Forwarders > Email Domain Forwarders and set the domain to foo.com and forwards to, to bar.com

I tried that and it works in my first few tests.

  • I can't see any connection between your title and the question. Please edit it to make it relevant. – John Gardeniers Feb 7 '13 at 7:55
  • So what does the sysadmin at bar.com say your MX records should be to forward email to the mail server there? And have they configured their email servers to accept email for foo.com? There's no point fiddling with the DNS settings until you know what the settings are supposed to be, and that the mail server is ready to catch what you're trying to throw it. – Rob Moir Feb 7 '13 at 8:04
4

Setting up the MX record for foo.com to point at bar.com only tells the Internet that mail for foo.com should be directed toward that specific server. It doesn't automatically configure that server to receive and process the mail.

The problem here is that your mail server at bar.com doesn't know that it's supposed to handle mail for foo.com. So since it doesn't know what to do with the mail, it must reject the mail. You are probably seeing weird bounce messages like "MX loops back to myself".

You can fix this by configuring the mail server at bar.com to also accept mail for foo.com. Exactly how you do this depends on the specific mail server in use, which is a detail not present in your question.

  • Thanks. That was one of my suspicions. The only bounce I've gotten to this point was when I had a typo in one of my tests. – Mighty Feb 7 '13 at 7:32
  • Good exact reply! "Allowed domains" could be tricky :) – xstnc Feb 7 '13 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.