We have a Windows Server 2003 R2 running Service Pack 2. It is a domain controller (Global Catalog) and our main internal DNS server. We run a System State backup of the machine to back up Active Directory information and save the backup to a different server.

This server has a single drive (C:), and we do have Shadow Copies enabled for the volume (which are completing successfully).

The System State Backup is now failing with the following listed in the backup logs:

Volume shadow copy creation: Attempt 1. "Event Log Writer" has reported an error 0x800423f4. This is part of System State. The backup cannot continue.

Error returned while creating the volume shadow copy:800423f4 Aborting Backup.

The operation did not successfully complete.

When doing a vssadmin list writers, we sometimes get the following reported for the Event Log Writer (other times it says that it is in the state of "[1] Stable" with "No error"):

Writer name: 'Event Log Writer' Writer Id: {eee8c692-67ed-4250-8d86-390603070d00} Writer Instance Id: {c7194e96-868a-49e5-ba99-89b61977753c} State: [8] Failed Last error: Retryable error

We have tried disabling the event log service via the registry, rebooting, deleting the event log files from the drive, then re-enabling the service via the registry and rebooting, but this didn't seem to solve the issue.

We also get an error message when in the event viewer when trying to open the log for the "File Replication Service" of "Unable to complete the operation on 'File Replication Service'. The security descriptor structure is invalid."

I have searched the error via Google and tried a number of different things, but nothing has seemed to help.

Any suggestions on what we might try to get the Event Log Writer to behave would be greatly appreciated!

5 Answers 5


Microsoft seems to have issued a hotfix for this problem and error code. I would test it well, though.

  • 1
    THanks for the link. Unfortunately this only applies to SP 1, not SP 2. We downloaded this hotfix but it says that there is no need to install the update ("Service Pack version of this system is newer than the update you are applying." message). Jul 29, 2009 at 21:51

The issue was resolved by fixing the Event Viewer error when opening the "File Replication Service" log:

"Unable to complete the operation on 'File Replication Service'. The security descriptor structure is invalid."

The registry value for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\File Replication Service\CustomSD was blank. I entered the value from another domain controller:


This resolved the error when opening that log file, and resolved the issue with System State Backups failing.

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\File Replication Service\CustomSD is of type REG_EXPAND_SZ.
    – Pro Backup
    Dec 6, 2017 at 21:30

Isn't having shadow copies/previous versions on the same volume as your sysvol share an unsupported config? I can't find any definitive info on this right now, but there's something nagging at the back of my mind about it...

  • Unfortunately, even if we disable the Shadow Copies on that volume, we still get the same behavior when running the backup. I included that info to at least show that some part of the VSS subsystem was functional. Jul 29, 2009 at 21:54

Had the following issue

Event Log Writer" has reported an error 0x800423f4. This is part of System State. The backup cannot continue.

Found the problem was a lack of disk space on the System partition. Once I cleaned it up a bit, the system state went through no problem

  • We have about 6 GB of free space on the system partition (out of about 20 GB), so space doesn't seem to be the issue. Dec 22, 2009 at 17:04
  1. Open Registry editor
  2. Expand HKLM\System\CurrentControlSet\Services\Eventlog\Security
  3. Check the value of the registry key "File" and make sure its set to
  • I checked the registry on this machine, and the path is set correctly. Dec 22, 2009 at 17:03
  • @Pawan Our HKLM\System\CurrentControlSet\Services\Eventlog\Security\File is set to %SystemRoot%\System32\winevt\Logs\Security.evtx.
    – Pro Backup
    Dec 6, 2017 at 21:34
  • @Pawan After changing "File" to %SystemRoot%\System32\winevt\Logs\Security.evtx the error changes to 0x80042301.
    – Pro Backup
    May 26, 2019 at 7:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .