7

I have a machine with CentOS 5.9 and VMware installed.

Currently I am using BIND 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.6 (default shipped with distribution).

When I restart the machine, I can see this message on screen just when the named service is started:

Starting named: You need to implement a remote task_setrlimit in your security module and call it directly from this functionWARNING: at security/security.c:51 security_ops_task_setrlimit()

Call Trace:
[<ffffffff8012eeeb>] security_ops_task_setrlimit+0x87/0x96
[<ffffffff8009dc0a>] do_prlimit+0xd7/0x1d2
[<ffffffff8009ed53>] sys_setrlimit+0x36/0x43
[<ffffffff8005d29e>] tracesys+0xd5/0xdf

This error doesn't seem affect to bind, the service works fine, but I would know what produces the warning error and how to solve it.

7

This message is harmless and can be ignored. It is a note to kernel developers.

Red Hat also published a statement to this effect in its KB (subscribers only, boo).

| improve this answer | |
0

I got rid of this message at console, adding this to /etc/rc.local :

echo 3 > /proc/sys/kernel/printk

| improve this answer | |
  • 1
    This seems to address the symptoms, more than the problem. One generally doesn't turn off logging to resolve errors being logged... I'd hope that sometime the responsible kernel developer might issue a patch for that. – Falcon Momot Oct 2 '13 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.