3

This message was received by a mailing list maintainer, that one of our customers subscribed to:

host mailx.paritaet-bremen.de said: 550 213.30.233.146 is not allowed to send mail 
from gmx.de (in reply to RCPT TO command)

I don't get what this is about. Some answers here suggest blacklisting, but neither host is on any black list I've searched. Seems like a misconfiguration. If so, who is to blame and how to remedy the situation?

2 Answers 2

7

gmx.de has SPF record with -all:

v=spf1 ip4:213.165.64.0/23 ip4:74.208.5.64/26 ip4:212.227.126.128/25 ip4:212.227.15.0/25 ip4:212.227.17.0/27 ip4:74.208.4.192/26 ip4:82.165.159.0/24 -all

most likely your recipient's mail server checks this record any denies incoming from your IP according to the record recommendation.

3
  • After some searching, it seems SPF is a bit controversial. Do you have an oppinion whether we should use it on our customers mail server?
    – möter
    Feb 11, 2013 at 17:34
  • Instead of -all use ?all. That way you can consult with SPF but not use it alone to drop incoming mail.
    – adamo
    Feb 12, 2013 at 6:44
  • 1
    I don't use it. As for me it brings more mess than fixes problems. But for large services like gmx.de it could be reasonable. Many spamers use their domain addresses in From: of spam messages, so SPF might be of use. And with -all only, if you specify ?all - you loose all the benefit. Yes, it will be more safe, but useless. Feb 12, 2013 at 11:16
-1

The above error means that the mail from gmx.de was rejected due to spf setting. The sender domain: gmx.de have SPF setting that do not allow to send the email from the IP 213.30.233.146. The spf is to prevent any mail forgery, spam issue, email spoofing and etc. The basic SPF setting is v=spf1 a mx -all. To confirm if this string exists, log in to your cpanel>Advance DNS Zone then check for a string which looks like:

gmx.de. 14400 IN TXT v=spf1 a mx -all Edit Delete

[v=spf1]: This identifies the TXT record as an SPF string. [a]: refer to the domain IP . The domain is allowed to send mail through this A record [mx]: refer to the domain MX record. The domain is allowed to send mail through this MX record [-all]: No other servers are allowed to send mail from this domain

So you can click on delete to remove the string from your account first before you be able to send and receive mails normally. Once its deleted the issue will be solved. I hope this helps.

3
  • This seems to me to add nothing to the other answer, except cpanel-related suggestions - which the OP has not indicated (s)he uses, and which would be off-topic for SF anyway.
    – MadHatter
    May 8, 2015 at 7:19
  • Upvoted - Come on, this is a brand new user. I think commenting with suggestions is merited, but are the two downvotes necessary? Hope you give SF another shot, priscah malo! @MadHatter has some good suggestions - please follow them. Looking forward to seeing you around! :)
    – rinogo
    Dec 30, 2015 at 2:31
  • P.S. I also upvoted the "more correct"/original answer :)
    – rinogo
    Dec 30, 2015 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.