I'm trying to dump my SVN repository in a scheduled task. The problem is that when it's running in the scheduled task its only outputting a part of the repository (about 476MB instead of about 2G).

Scheduled task is in a bash file, script is:

svnadmin dump /home/it/svn/source > /home/it/IT_backup/backups/source.dump

I think I know the issue...since I ran into the same exact thing.

See here: Subversion backup dump - just need something very simple

Here's what I found to fix it:

You have to redirect output such as svndump.sh > /var/log/svndump.log 2>&1

This will cause the script to finish correctly. I forget why to be honest...but it works.

| improve this answer | |
  • 1
    That Worked! Thanks! can anyone help explain why? – Amit Ben Shahar Feb 14 '13 at 7:27
  • I wish I could find the page I found the answer on...so far no luck and I'm not a Linux admin. If I find it I'll post back here. – TheCleaner Feb 14 '13 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.