i have ldap server and ubuntu clients ,as they login is working perfectly and no problems at all , but when user change his password he also can login with the new password but he can't login with the old password and the is the right , but if the screen is went locked then he can unlock the screen with the new password and the old password too,

so can any help please ?

closed as not a real question by HopelessN00b, Dave M, mgorven, mdpc, Ward Feb 15 '13 at 6:07

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is the nscd service running? You can stop it to disable local caching of credentials. – Aaron Copley Feb 14 '13 at 17:13
  • If you're using sssd, use the sss_cache command to clear caches + sssd.conf has 3 PAM related options dealing with offline authentication. – fuero Feb 14 '13 at 17:55
  • @AaronCopley the nscd is already running and i stopped it now , how can i remove the cached credentials ? – Moaz Refat Feb 17 '13 at 10:11
  • @fuero the sssd service is already not running – Moaz Refat Feb 17 '13 at 10:11

It's hard to tell, but this sounds like expected behavior. The client machines has the old password cached, and thus, can unlock the machine with the old password. If the user enters a different password than the cached one, the client machine checks the LDAP server to determine if it's a valid password, and gets the new password.

If this is causing a specific problem, you should probably ask a question (or do a search) about how to disable client-side password caching.

  • this user can't unlock with the old password from any another machine , this mean that definitely it is password cached in the client site but where is it ,this the issue . – Moaz Refat Feb 14 '13 at 14:07
  • i found the solution that there is a file called .security.db in the following path /var/cache/ remove it or move it to any another place. it works like charm. thanks you – Moaz Refat Feb 17 '13 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.