I run into this error every time I try to update (CentOS 6) on four different servers. It only happens with this package. After researching the problem, I haven't been able to find any useful info. People have had very similar problems to this, but not this particular one. Can anyone offer me any advice on how to fix this issue?

[user@machine ~]$ sudo yum update
Loaded plugins: dellsysid, fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.thelinuxfix.com
 * extras: mirrors.gigenet.com
 * rpmforge: thammuz.tchpc.tcd.ie
 * updates: mirror.clarkson.edu
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package srvadmin-omcommon.x86_64 0:7.2.0-4.450.1.el6 will be updated
---> Package srvadmin-omcommon.x86_64 0:7.2.0-4.459.1.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

 Package              Arch      Version                Repository          Size
 srvadmin-omcommon    x86_64    7.2.0-4.459.1.el6      dell-omsa-indep    1.8 M

Transaction Summary
Upgrade       1 Package(s)

Total download size: 1.8 M
Is this ok [y/N]: y
Downloading Packages:
srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64.rpm           | 1.8 MB     00:05
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package srvadmin-omcommon-7.2.0-4.459.1.el6.x86_
cp: cannot stat `/opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/ini/*ini': N
o such file or directory
error: %pre(srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64) scriptlet failed, exit s
tatus 1
error:   install: %pre scriptlet failed (2), skipping srvadmin-omcommon-7.2.0-4.
srvadmin-omcommon-7.2.0-4.450.1.el6.x86_64 was supposed to be removed but is not
  Verifying  : srvadmin-omcommon-7.2.0-4.450.1.el6.x86_64                   1/2
  Verifying  : srvadmin-omcommon-7.2.0-4.459.1.el6.x86_64                   2/2

  srvadmin-omcommon.x86_64 0:7.2.0-4.450.1.el6
  srvadmin-omcommon.x86_64 0:7.2.0-4.459.1.el6

[user@machine ~]$

This is most likely to be a bug in the way the package was put together (by Dell). Since they're referencing files in the %pre section that can't be assumed to exist before the package containing them is installed (that same package!) it's almost certain this is an error on the packager's part. Most likely such commands should have been in a %preup or %post section instead, depending on what it is they're trying to do. As such, you should report the problem to Dell.


I would guess that srvadmin-omcommon might be dependent on another rpm. For srvadmin-omcommon-7.1.0 (what I have here), /opt/dell/srvadmin/etc is provided by srvadmin-omilcore, so if that rpm isn't installed, then the rest of the path may not be able to be created. However, all dirs down to ini seems to be provided by srvadmin-omcommon:

# rpm -qf /opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/

so there is possible another issue. You can list the scripts by doing:

rpm -q --scripts srvadmin-omcommon

and see what pre is doing. My srvadmin-omcommon-7.1.0 doesn't have a pre, just postinstall and postuninstall, so I can't check with mine.

  • When I run the rpm -qf: [user@machine ~]$ rpm -qf /opt/dell/srvadmin/etc/openmanage/wwwroot/oem/data/ srvadmin-omcommon-7.2.0-4.450.1.el6.x86_64 srvadmin-omacs-7.2.0-4.459.1.el6.x86_64 [user@machine ~]$ – Chris Powell Feb 14 '13 at 20:51
  • When I run the second command: [user@machine ~]$ rpm -q --scripts srvadmin-ocommon package srvadmin-ocommon is not installed – Chris Powell Feb 14 '13 at 20:57
  • You may have done a typo, it is srvadmin-omcommon. – lsd Feb 14 '13 at 22:26
  • Oh, so it is. I'll try again and report back. – Chris Powell Feb 19 '13 at 14:11
  • Ok, the first command's output stayed the same. The output for the second command was too long, so I put it in a txt file on dropbox. https://www.dropbox.com/s/6ppl81hho1zmzpu/RPM%20Output.txt – Chris Powell Feb 19 '13 at 14:25

I think you have 32 bit version of the Dell OMSA.

OMSA and firmware update packages were previously only available as 32-bit binaries, but are now available 64-bit native for x86_64 systems.

Warning: If you have a 32-bit Dell package installed (srvadmin-* dell_ie*) on your system, it continues to use the 32-bit packages. To use the 64-bit packages, uninstall the existing 32-bit packages before installing them. New installations install the architecture of OMSA that matches your operating system.

Source: Dell OM 7.2 Linux Repository documentation

  • The question shows he already has the 64-bit packages. – Michael Hampton Feb 14 '13 at 21:58
  • I think he still have the 32 bit portions somewhere. The dependencies are not ok in the Dell RPMs. Many times I had to uninstall Dell OMSA and re-install it. It is not that hard, just a: wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash;yum install srvadmin-all – Mircea Vutcovici Feb 14 '13 at 22:02
  • Maybe he does, but I don't see any evidence of that in the question. – Michael Hampton Feb 14 '13 at 22:03
  • You are right, and I agree with your point. But it was the problem that I have encounter in the last Dell OMSA upgrades. It is just a long shot. – Mircea Vutcovici Feb 14 '13 at 22:10
  • As far as I know I have the 64 bit packages. Perhaps an uninstall/re install is the best path to take. – Chris Powell Feb 19 '13 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.