I'm trying to access the report manager, which in my case is located at http://localhost/Reports. When I try to go there I get the following error:

User 'ComputerName\UserName' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

It seems that all the information I can find pertaining to this error has to do with trying to access the Report Server Web Service URL (which of course gives me the same error), and the solution to that problem requires access to the Report Manager so that's not very helpful. Also I've tried running my browser as an administrator as suggested by one solution but it didn't make any difference.

I am using Windows 8 and there is no domain. I am logged in as the same user that was used to install the operating system as well as all other software and it has sysadmin rights on the SQL Server Database Engine. Let me know what else you need to know and I'll post it asap.


Here's how I solved this:

1) Turned on 'the' administrator account via command line:

net user administrator /active:yes

2) Logged in as the built in admin and opened the browser as an administrator

3) Successfully went to http://localhost/reports and assigned my regular admin account all the rights it needed.

I'm not sure what the difference is between the built in administrator account and my account which is an administrator. I noticed that when I selected 'Run As Administrator' to open the browser it didn't give me the normal message box to confirm, which makes me wonder whether I could have just temporarily disabled the UAC on my regular admin account and accomplished the same thing.

If anyone has any more detailed info on this please do share because I will eventually be needing to do this on many installations and would definitely like to know if there's a way I can do this without having to enable the built in admin account.

  • +1. Enabling the administrator account did the trick for me. I didn't actually have to log in as the administrator in Windows; I just re-opened the http://localhost/reports URL and logged in as 'Administrator' instead of my own user account. – Matt Browne Aug 6 '15 at 19:10
  • Actually it turns out that I could only view reports that way and didn't have any other permissions, and logging in as administrator didn't help either (this may be because I'm on Windows 7 Home edition). I solved it by disabling UAC: windows.microsoft.com/en-us/windows/… ...of course now I see that the answer below mentions disabling UAC. – Matt Browne Aug 10 '15 at 18:38
  • This worked for me. Was frustrated until I realized I wasn't running my browser as admin. Definitely remember to do that. – bchilders Jul 19 '17 at 18:01

I struggled with this as well. It was impossible in Windows 8 with my own "admin" account to get the Report Server working. Worse yet I had forgotten the administrator account password I used to set up the computer.

You have to enable the administrator account in Computer Management => Local Users and Groups => Administrator; right-click, select Properties, and ensure that the "Account is disabled" check box is unchecked. Once you've done that, reboot, and at the login screen select the administrator account. If it helps, I think the password is one that has to have a capital letter and a number. It took me a few tries.

Once in the administrator account, disable UAC. To do this, open the Control Panel and type "UAC" and select the Change User Account Control option. Move the slider all the way to the bottom. You will have to reset this setting later.

Finally, configure the report server using the Reporting Services Configuration manager. I won't go into the steps here, as they are outlined elsewhere and it's a process of its own. Once you are done, click on the Report Manager link (on my machine, it's located at http://localhost:80/ReportManager --but, nevertheless, it's under the Report Manager URL tab). From there you can configure additional account access. Add your user account as an administrator, and close the window. Reset your UAC settings in the control panel. Finally, sign out of the administrator account and back into your user account.

Why this process is so complicated is beyond me. I will refrain from critical comments about any of our fellow developers or their companies.


I was on the same issue even running chrome as admin, but keeps same error, something strange is that only running classical internet explorer as admin allows this to work, there you can ad your own user as admin (as system administrator and content manager) and there you're free to go, on any browser would then work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.