3

We're implementing some new alarms recently that needs to monitor CPU for 1 min period. Alarms are acting in very strange way. They show Good status for a min and for the min after they show Insuffucient data sign

Reason: Insufficient Data: 1 datapoint was unknown.

  • Does this mean any problems in the configuration?
  • If the alarms condition meet, will fire in all cases or not?
9

Do you have detailed monitoring enabled on your instance?

If you create CloudWatch Alarms for period 1 minute without detailed monitoring enabled, it will stuck at Insufficient Data for 4 minutes after showing OK for every 5th minute . This is because with normal monitoring the reporting data comes with the interval of 5 minutes whereas in detailed monitoring, this interval is 1 minute.

If you do not want to enable detailed monitoring which is paid, change all alarms to 5 minutes period and it will be all fine.

I think Amazon should not let users create alarms for 1 minute period when detailed monitoring is not enabled. This is not your fault.

0

I just came across this CloudWatch issue. To resolve, I had an old auto-scaling group named in my rule that was still running and had not been updated to our new auto-scaling group name.

1) Go into your Auto-Scaling Group 2) Select the Scaling Policies tab 3) Check your policy name where it says Execute policy when

If your name does not match your current Auto Scaling Group, select Create New Alarm and create a new alarm for your new group.

1
  • This isn't related at all to the question. I didn't mention AutoScaling at all. It's CloudWatch only issue – Bassam Gamal Jan 15 '14 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.