I am trying to install the .NET framework 4.0 on my Windows Server 2008 R2. I had it installed before, but for some other reason I uninstalled and now wan't to reinstall it.

My problem is, there is a file C:\windows\system32\aspnet_counters.dll which cannot be written in the installation process and thus it fails.

Looking into windows explorer, I can see the file is already there.

  • It has 0kb.
  • Deleting it fails ("The system cannot find the file specified").
  • Renaming fails too (same message).
  • Cut & paste also (same message).
  • properties -> security tab says "security info is not available or cannot be shown"
  • I tried Unlocker1.9.1-x64 but it didn't seem to work at all
  • I tried "del /f aspnet_counters.dll" (as administrator), but no success. It said "The system cannot find the file specified".
  • I tried the .NET cleanup tool (http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx), but no success. I guess it cannot access the files either.
  • I tried "chkdsk /r /f". No success.

Additional info: it is a virtual server XXL from hosteurope.de.

So, my question is: how do I remove this file? Is the file system broken here? Any recommendation is appreciated. Thanks!


This is a symptom of a deleted file that still has an open file handle somewhere. If you can't find it in Process Explorer, then you will need to restart your server to clear the file handle.


Try running Process Explorer. Use the search feature to verify that no process has the file open.

The other option would be to boot to a Windows install CD and use the built-in command prompt (press Shift+F10 during setup) to delete the file. This should work unless the filesystem is corrupt, but you said you already did a "chkdsk /f".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.