In Microsoft Word if you click on Insert> SignatureLine, you will see this message:

enter image description here

We provided our client the ability to sign their document via certificates automatically genereated using our Microsoft Root CA and pushed to the client via group policy. When they try to sign the document they get prompted for third-party digital signature services from office marketplace. Since we have already provided them the certificates they need we would like to prevent them from seeing this prompt.

We have reviewed the document published by Microsoft, For IT professionals: Group Policy for Microsoft Office 2010 but have not found any settings that would allow us to not show this message.

Is there anyway way through group policy to automatically check the Don't show this message box so that the users is never prompted with this option?

  • The user can be instructed to tick the Don't show this message again box, then click Ok. I guess you are asking to do this centrally for all users so that the users aren't bothered by the message, or don't otherwise screw up the rest of your config. Is that right? – dunxd Feb 19 '13 at 14:58
  • You are exactly right. we want to be able to do this for all users centrally. – hosein izadi Feb 19 '13 at 15:09

I figured out that when you tick the Don't show this message again box, and click Ok, this action generate new registry key.

This is the path in registery: HKCU\Software\Microsoft\office\14\Common\Signature\SignatureUISettings

The key is REG_DWORD and the value is 448( in Decimal).

Basically if you make this register key and push it by GPO to the users, they never get that message that we had issue with.

If you want to test it, you can just make this regkey, and then delete it to see the diiferent.

  • +1 for detective work; I was going to suggest that this is what you want to do. There are tools from sysinternals that show live registry changes, or you could dump the nodes before and after clicking OK and diff them. – Mark Henderson Feb 20 '13 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.