I've been getting errors whenever I try to run the task scheduler for Windows 2008 R2. Each time that I've tried running it, the task scheduler will crash and report the following:

Problem signature:

  Problem Event Name:   CLR20r3
  Problem Signature 01: mmc.exe
  Problem Signature 02: 6.1.7600.16385
  Problem Signature 03: 4a5bc808
  Problem Signature 04: System.Windows.Forms
  Problem Signature 05:
  Problem Signature 06: 50c29e85
  Problem Signature 07: 151f
  Problem Signature 08: 18
  Problem Signature 09: Exception
  OS Version:   6.1.7601.
  Locale ID:    1033

I've been looking online but so far I keep finding mixed results on what could be the fix for this and was wondering if anyone here has ever ran into this issue before. I read that this issue could be because of Security Update for Microsoft Windows (KB2449742) and that by uninstalling it I would be able to fix this issue, however I was not able to locate this anywhere in the server.

Here's the link if interested

Patch wise, everything is up to date. Also, I tried running hotfix KB2688730 to see if that would work after doing some research online, however the hotfix is not applicable to the computer.

If anyone could provide some information on how to fix this and get the task scheduler running again it would be extremely helpful!

  • I've experienced crashing mmcs when I had both 2005 SQL Management Studio and 2008 SQL Management Studio installed at the same time. Uninstalling one of them fixed it. This is gonna' be tough to troubleshoot though since so many things, such as the exact combination of installed software, can cause it. – Ryan Ries Feb 23 '13 at 22:41

have you tried moving/deleting the MMC snapin settings file? Files for MMC usually sit in the c:\users\\AppData\Roaming\Microsoft\MMC folder (windows 7/8). I don't remember off the top of my head the exact folder for XP and earlier. But it should be under the c:\documents and settings\\ in a folder named MMC. You will probably see a few. You are looking for the filenames "taskschd". Try just moving the file with MMC closed and see if that helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.