1

I have had a wildcard SSL cert installed on my linux server by one of our IT guys.

When i access my site now with just http in the url bar everything works fine and the site shows up

When i access my site via this link: https://mydomain.co.uk the site automatically redirects to https://mydomain.co.uk/cgi-sys/defaultwebpage.cgi.

Any ideas why this could be? I read into that it could be DNS and caching issues along with propagation. I have left it a few days now and is still the same. I have restarted apache on the server, and also had the certificate re-installed multiple times.

It was also suggested to upgrade to the latest version of cpanel/whm which i did and made no difference.

Any help would be greatly appreciated, as im pulling my hair out! Thanks, Dan

closed as off-topic by masegaloeh, mdpc, Andrew Schulman, Hyppy, Khaled Apr 30 '15 at 14:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • If you're willing to give the domain name publicly, and post your httpd.conf, we may be able to help. Otherwise, I find it a bit of a guessing game. – MadHatter Feb 20 '13 at 16:39
  • 2
    Don't see how this is a DNS or SSL issue, sounds like a webserver configuration issue. – mgorven Feb 20 '13 at 16:45
  • @MadHatter the url is indigoapps.co.uk how can i access the httpd.conf to post it? – danyo Feb 20 '13 at 16:46
  • @mgorven i am only posting what i have found on cpanel forums – danyo Feb 20 '13 at 16:47
  • 1
    /etc/httpd/conf/httpd.conf and the contents of /etc/httpd/conf.d. I'm not sure about the propriety of putting that all in your question (it might be quite long) so you might want to investigate one of the pastebin-like services. – MadHatter Feb 20 '13 at 17:16
2

A new Apache VirtualHost would have been created for the HTTPS instance, you're being redirected to the default page because this virtual host has no content yet. HTTP and HTTPS virtual hosts are separate and distinct in Apache.

Depending on what you want to do with the HTTPS version, you could copy all the HTTP settings over, or possibly change the DocumentRoot to point at the same place that the HTTP version uses.

I think this should be relevant and help you figure out the paths: http://docs.cpanel.net/twiki/bin/view/EasyApache3/InsideVHost

There are no evident issue with DNS or the cert itself, it even has a SAN of "indigoapps.co.uk" so it will work with or without "www".

Not the answer you're looking for? Browse other questions tagged or ask your own question.