1

I've installed a Reddit Clone in an EC2 server and I am getting an error that says:

error connecting to amqp reddit @ localhost:5672 (IOError('Socket closed',))

As I checked using nmap on what ports were open and 5672, or the RabbitMQ port wasn't open. I tried restarting the rabbitmq-server already but to no success. I haven't touched any configuration files yet.

Is there anything I'm supposed to do before rabbitmq successfully listens to port 5672?

EDIT: I've solved my problem, I uninstalled RabbitMQ and installed it using the guide on the site http://www.theprogrammer.co.za/wordpress/2012/08/installing-rabbitmq-on-ubuntu-12-04-lts/. Something might have been wrong in the installation script of reddit, that didnt work in my favor

1

Try 15672 if you're on 3.0+ or 55672 if you're on an earlier version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.