0

I am trying to do rdesktop from centos linux to a windows machine but I am just getting below message

$] rdesktop xxx.xxx.xxx.xxx:port

Autoselected keyboard map en-us

And no UI. What Am I doing wrong?

  • 1
    I dunno, but here's my syntax. Adjust to your needs. Note: -k de is for a german keyboard layout. rdesktop -g 1920x1020 -x 0x80 -b -k de -u YOURUSER -d YOURDOMAIN -p YOURPASS -r clipboard:"PRIMARYCLIPBOARD" -r sound:"local" YOUR-REMOTE-MACHINE – Malte Stein Feb 21 '13 at 13:57
  • What version of Windows? Have NLA configured? – Chris S Feb 21 '13 at 14:11
  • Not directly related, but you might want to look at the freerdp fork. It has better support the new versions of Windows. – Zoredache Feb 21 '13 at 17:30
2

I suggest that you check the following:

Is remote desktop port reachable (default is 3389)?

telnet <ip_of_win_machine> <rdesktop_port>

Are you trying to use remote desktop on Windows 7 Starter, Windows 7 Home Basic, or Windows 7 Home Premium? If so then you may not be able to do it since they do not ship with remote desktop and I am not sure if it can be installed later.

And do check the Windows Event Viewer, in case there is something there.

  • no i am using rdesktop on linux. You were right though issue was with port. – Drt Feb 28 '13 at 10:39
  • Please mark the answer as right if it helped you. Thanks :) – Aditya Patawari Feb 28 '13 at 10:48
0

The solution was there was a need of port forwarding in my network

After doing that, I used rdesktop and it worked fine. Also I have added some more rdesktop options to it specifically -f for full screen and -g 1440x900 -P -z -x l -r to make it's performance better.

rdesktop -f -g 1440x900 -P -z -x l -r -u windowsuser remoteipaddr:newport

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.