I've seen this question asked many times on serverfault (and other places), but have not found a solution.

I'm using Squid version 3.1.19 standard Ubuntu 12.04 package.

I get the following error in a browser:

The following error was encountered while trying to retrieve the URL: http://www.standardandpoors.com/home/en/us

Unable to determine IP address from host name www.standardandpoors.com

The DNS server returned:

Name Error: The domain name does not exist.

This means that the cache was not able to resolve the hostname presented in the URL. Check if the address is correct.

From the proxy server I can resolve the address just fine.

access.log error: 1361372441.048 216 TCP_MISS/503 4907 GET http://www.standardandpoors.com/home/en/us - DIRECT/www.standardandpoors.com text/html

For some reason it does not seem to be resolving and the DIRECT peering code is showing the hostname instead of the ip. IPs do show up on every other request. log_ip_on_direct is on

I've tried disabling caching, explicitly using the dns_nameservers directive, even putting the host in /etc/hosts. Any help is appreciated!

I discovered that when I use a public DNS with dns_nameservers (I tried with the IP resolves and I don't get a squid error. I can't use a public DNS for intranet etc. so it's not a solution. Also as I mentioned before it resolves with nslookup.

Another strange thing is that a packet capture when trying to browse with a browser on the server not going through the proxy shows:
DNS Standard query response, No such name

A capture when doing an nslookup from the same server shows: DNS Standard query response A

EDIT Using the WinGate proxy with the same local DNS servers works.

  • So fix your intranet's DNS server. – Michael Hampton Feb 22 '13 at 16:38
  • I have the same problem on Debian with squid 3.1.20, what kind of DNS servers do you use ? Windows servers ? – user161922 Feb 28 '13 at 11:41
  • Yes Microsoft DNS Version: 6.1.7601.17514 – user160922 Feb 28 '13 at 17:07

Delegation of the zone "www.standardandpoors.com" (note the zone begins www) is broken.

The servers for standardandpoors.com say there are two name servers for www.

These two servers answer for A requests but not for "NS" requests, or other requests - despite claiming to be BIND 9.4.3-P3. They answer for SOA requests for the parent domain.

I assume either some sort of load balancer (I've seen them broken like this before), or just the normal borked nature of many DNS delegations. BIND 9 seems to handle this form of borked delegation adequately.

As others asked - what name servers are not handling this well? Are you messing with forwarding, or slaving zones, or similar internally?

  • No forwarding or slaving zones. These are Microsoft 2008 DNS servers. Can the only solution really be switching to BIND? – user160922 Mar 6 '13 at 19:49
  • I was able to "fix" this issue by adding www.standardandpoors.com to /etc/hosts on the squid server, thanks for pointing me in the right direction. – user160922 Mar 14 '13 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.