4

I need to install Lotus NotesSQL Driver (current version is 8.5) onto a virtual machine running XP. Here's what's I've done so far:

  1. I retrieved the file (CZOWFEN.zip) from the IBM website.
  2. I ran the exe.
  3. I then went to My Computer->Properties->Advanced->Environmental Settings->System Variables->Path and added "; c:\notessql" so the ODBC Administrator could find Notes.ini (why the setup file didn't do this in the first place, i don't know).
  4. I opened up the ODBC Administrator and tried to add a new System DSN to a Lotus DB.

    "The setup routines for the Lotus Notes SQL Driver (*.nsf) ODBC driver could not be loaded due to system error code 126"

  5. I redownloaded and reinstalled the driver (making sure I had the latest version 8.5). No luck.
  6. I checked the registry. All the file paths appeared to be correct.
  7. Per many, many similar cases on the internet, I tried several different variations of adding the various Lotus Notes folders to my PATH variables. Same error.

I've done this setup on 5 different machines now with no problem. The only difference here is that this machine is virtual. Ideas?

  • What VM software are you running? – Ken Pespisa Jul 30 '09 at 20:09
  • I believe the name is "VMware tools". – PowerUser Jul 31 '09 at 14:34
  • "VMware Virtual Platform" – PowerUser Jul 31 '09 at 14:39
5

was your notes.ini located in the \Lotus\Notes directory ?

NotesSQL expects to find Notes.ini in the \Lotus\Notes directory. If the file is not in this directory, the driver may crash when you use the ODBC Data Source Administrator to create a DSN, or the NotesSQL Authentication List Manager may report that it is unable to find a valid version of Notes. If you must place Notes.ini in a directory other than \Lotus\Notes, add the directory to your PATH environment variable.

  • Adding "C:\Lotus\Notes\" to the PATH environment variable did the trick. – PowerUser May 27 '10 at 14:00
  • notes.ini was in C:\Program Files (x86)\Lotus Notes, so I added that to my path and it did the trick. – Michael Plautz Oct 21 '16 at 14:45
2

I found that adding C:\Program Files\IBM\Lotus\Notes\ (which is what the registry setting HKLM\Software\Lotus\Notes\Path points to) to the PATH works for me.

1

Does the NNotes.dll is in the PATH? (if not you need to add it in the path) solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.