4

Postgresql 8.4 seems to be installed properly, according to this:

sudo yum install postgresql 
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security, subscription-manager 
This system is not registered to Red Hat Subscription Management. You can
use subscription-manager to register. 
This system is receiving updates from RHN Classic or RHN Satellite. 
Setting up Install Process 
Package postgresql-8.4.13-1.el6_3.x86_64 already installed and latest version
Nothing to do

However, when I try to run this, it's unrecognized:

$ sudo /sbin/service postgresql initdb
postgresql: unrecognized service

This is RHEL 6.3

7

You need to install postgresql-server to get the System V init scripts and server binaries.

| improve this answer | |
  • 1
    Of course... sudo yum install postgresql-server worked... – jgritty Feb 27 '13 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.