I'm currently trying to move a RHEL based server to Citrix XenServer (5.6) VM.

My plan was to use Clonezilla LIVE CD, which i have had good suceess with to clone physical to physical before. So i have already created the image of the physical server.

I have created a new VM in XenCenter, with 1 single CPU and 1Gb Memory - for simplicity - will put more resources in later.

However on the restore part, I can boot Clonezilla on an new VM and i get the splash screen where i can choose different modes of Clonezilla. But i have never gone successfully past the first splash screen. The ISO's are located in a network share.

Now i have tried different builds of Clonezilla, both default Debian and the alternative Ubuntu based, in amd64 and i486 flavors. 4 ISO's in total.

a) clonezilla-live-2.1.0-26-amd64 : Stopping at below lines, with blinking carriage after

[2.808077] Refined TSC clocksource calibration: 2666.841 Mhz
[2.808108] Switching to clocksource tsp

b) clonezilla-live-2.1.0-26-i486 : Stopping with a black screen

c) clonezilla-live-20130226-quantal-amd64 : Stopping with a white screen

d) clonezilla-live-20130226-quantal-i386 : Stopping with a white screen


Are you P2V ? If yes follow the step

Step 1 use "clonezilla Live CD"
Step 2 boot using Clonezilla Live CD 
Step 3 Choose language in Clonezilla live
Step 4 Keyboard selection in clonezilla live
Step 5 Enter clonezilla or shell command (choose shell command)
Step 6 Choose option "2"
Step 7 You'll get "$" prompt 
Step 8 $ sudo bash
Step 9 # ifconfig eth0 XXX.XXX.XXX.XXX
Step 10 # passwd (change root passwd)
Step 11 # /etc/init.d/ssh restart
Step 12 Create new VM with HDD/CPU/MEM
Step 13 Boot VM with Clonezilla Live CD
Step 14 Follow above 11 step
Step 15 # dd if=/dev/sda |gzip -c | ssh root@target ip address 'gzip -d | dd of=/dev/sda'
Step 16 reboot VM
|improve this answer|||||
  • Did you read my post?? – Phliplip Mar 4 '13 at 16:25
  • But yes, it's P2V... – Phliplip Mar 4 '13 at 16:26
  • I have read you post, I don't want you to get in more issues so that is my suggestion which I have tested p2v/v2v/v2p. – Rajat Mar 4 '13 at 16:44
  • In my post i clearly state that i have an image of the server that I want to move to virtual. My problem is that i can't boot Clonezilla on the Citrix XenServer VM... But I apreciate your alternative way of doing the actual clone, haven't thought of moving it over network. But in that sense, wouldn't I be able to do that with any other live CD? – Phliplip Mar 5 '13 at 7:42

ParaVirtualized guests by definition have-to-have a modified kernel. Same reason that MS Windows will not boot paravirtualized. So this leaves us with seven options:

  1. Convince Steven Schiau or xen.org or someone to create a clonezilla version using xen Linux, then you would be able to boot the ISO under a paravirtualized environment.
  2. Make a backup of your current pvm configuration. Modify it to run as full HardwareVM or HVM. Boot clonezilla and clone the RedHat image to the xen disks. Shutdown the HVM version of your PVM. Change the configuration back to PVM. Boot RedHat PVM.
  3. Shutdown your existing PVM. Create a new HVM and attach the disks to this new HVM from the PVM. Boot the new HVM with Clonezilla and clone over from the RedHat image. Shutdown this temporary HVM. Boot the original PVM that will now boot with RedHat disk images.
  4. Permanently convert the existing PVM to a HVM. All of us have infinite money, therefore infinite CPU and RAM.
  5. Follow the answer from @Rajat except substitute an already paravirtualized LiveCD in his "Step 13 Boot VM with Clonezilla Live CD".
  6. Follow ITProctology HowTo.
  7. Use xenconvert to convert the Clonezilla image directly to a xen usable image. Depends on type of original image.
|improve this answer|||||

Works in Citrix Xenserver 6.1(commercial) with the iso clonezilla-live-2.1.2-43-i686-pae.iso , the latest version in this moment.


|improve this answer|||||

I had the same problem too...until I tried to give my VM 4GB of RAM. I know, it sounds strange, but with 2GB assinged RAM:

b) clonezilla-live-2.1.0-26-i486 : Stopping with a black screen

While with 4GB assigned RAM it works perfectly, but only with the i486 version, AMD64 still gives black screen.

And if you suffer bad performance because of the emulated 100Mbit NIC, then just change it to an intel e1000, like explained in this article:


|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.