2

I am bootstrapping a ec2 ubuntu based chef node using chef, it creates an instance but it says Failed to authenticate ubuntu - trying password authand asks for the password. But a newly created ubuntu ec2 instance will not have any kind of password set. Throws an error

ERROR: Net::SSH::AuthenticationFailed: ubuntu@ec2-184-72-72-163.compute-1.amazonaws.com

How do I bypass this event and also whats the problem, do I have to make any changes in the configurations.

Kindly help me I am new to the chef.

| improve this question | | | | |
  • are you even pointing to your ssh key you used to setup the ec2 instance? – Mike Mar 5 '13 at 7:08
4

My guess is you aren't using this

-i IDENTITY_FILE, --identity-file IDENTITY_FILE
The SSH identity file used for authentication. Key-based authentication is recommended.
| improve this answer | | | | |
1

You can also use "ssh-agent" and use "ssh-add" on you private key to let ssh know you want to use it, without specifying the "-i" option with invocation of ssh.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.