Let's say that I have one RHEL6.2 64bit server running. Current latest version available is 6.4. Running "yum update" will update my server up to 6.4 straight away. What if I want to update only to certain point release?

For example, I want to update RHEL6.2 server only to RHEL6.3, not to 6.4. Any idea?

Thanks in advance,


Use subscription-manager to set the point release you want to lock your system to.

subscription-manager release --set=6.3
| improve this answer | |
  • This does not work for RHEL 6.2. – ewwhite Mar 8 '13 at 20:05
  • Really? You should call Red Hat and attempt to get your money's worth out of those subscriptions you're overpaying for. – Michael Hampton Mar 8 '13 at 20:07
  • The command switch "release" does not exist in 6.2. – ewwhite Mar 8 '13 at 20:14
  • Ironically, you probably need to upgrade to the 6.3 version of subscription-manager. – MikeyB Mar 10 '13 at 6:11
  • In that case you might try using the fallback of setting the --release when you register. But you really should call Red Hat. – Michael Hampton Mar 10 '13 at 6:13

I noticed this new workaround in the redhat KB:

Red Hat Enterprise Linux 6.2 Manually Setting a Preferred Operating System Release Beginning in Red Hat Enterprise Linux 6.3, Red Hat Subscription Manager could set a preferred operating system version to use to limit automatic updates for a system. This is covered in Section 5.7.4, “Setting Preferences for Systems”. However, it is not possible to set a preferred operating system through Red Hat Subscription Manager on older versions of Red Hat Enterprise Linux.

The system can be restricted to a certain operating system version on Red Hat Enterprise Linux 6.2 by editing the yum configuration. For example, to limit yum updates to 6.2-version packages:

[root@server ~]# echo 6.2 > /etc/yum/vars/releasever

Update: the above did not work for me on a new install of 6.2.

| improve this answer | |
  • Did you try this? – ewwhite Apr 25 '13 at 12:22
  • Just now -- and it didn't work. I also tried on another 6.2 VM to update the subscription-manager package so that the --release option becomes available. The subscription manager package was updated, but then it's giving me an error that no releases are available (even though the subscription shows as active). Still haven't found a way to prevent my server from updating. – alex9183 Apr 25 '13 at 12:30
  • Right. I've seen this documented, but it does not work at all. So again, this is still a mystery :) – ewwhite Apr 25 '13 at 12:33
  • Yep very frustrating! The message I get if I update only subscription-manager on a stock 6.2 install is: [root@mgmt-vcd2 ~]# subscription-manager release --set=6.2 No releases match '6.2'. Consult 'release --list' for a full listing. – alex9183 Apr 25 '13 at 12:54
  • It will work for 6.3 and newer, but that doesn't help existing 6.2 installations. – ewwhite Apr 25 '13 at 12:55

Alternately, after using "yum update" you can use "yum downgrade redhat-release"

Downgrade command will install the latest package before the last released. For example, if the latest is 6.4 it will downgrade to 6.3

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.