I have a Draytek 3200 router and a pfsense rackmount router that I am trying to get to route to each other.

I have a subnet on each router and a subnet for the link between, as shown here:

Network Map

As it stands at the moment I can ping from the Draytek subnet to successfully. I can ping from to I can't ping from the pfsense at all to the draytek's subnet.

Ultimatly I am trying to be able to ping anything on the subnet from any LAN on the pfsense.

Current pfsense Interfaces

Current Interfaces

Current pfsense Gateways

Current Gateways

Current pfsense Routes

Current Routes

I've allowed everything through on the firewall, as far as I can tell.

Draytek Subnet Configuration

Draytek Subnet Configuration

Draytek Static Routes

Draytek Static Routes

I'm certain I'm missing something and it's probably obvious, but I can't for the life of me get this working.

Draytek Routing Table

Key: C - connected, S - static, R - RIP, * - default, ~ - private
*            via       WAN1
S     via          LAN1
C     directly connected    LAN4
*  via       WAN1
C~    directly connected    LAN1
S~    via     VPN-3
S~    via  VPN-1
S~    via  VPN-5
S~    via    VPN-4
S~    via     LAN3
C    directly connected    DMZ 
S  via     WAN1
C  directly connected    LAN1

I wasn't sure if it's relevant but the two routers are not directly connected via a patch cable as the Draytek only has one true LAN port. The LAN 4 on the Draytek is tagged, passed to a switch which is set to untagged on the port the pfsense is connected to.

enter image description here

PFSense Firewall Log

Firewall Logs
ACT IF    Source       Destination     Prot

Core Switch VLAN Config

enter image description here

  • Does the draytek need a static route for something directly connected to it? – NickW Mar 5 '13 at 15:15
  • I'm not sure - but without the static routes it still fails. – dannymcc Mar 5 '13 at 15:16
  • hmm, got a bit confused there.. obviously that static route is fine. You need to make sure that the firewall on the Draytek is completely disabled also. – NickW Mar 5 '13 at 15:36
  • Firewall and QoS is all disabled. – dannymcc Mar 5 '13 at 15:52
  • 1
    I think I have spotted it! Why are you routing through LAN1 to get to the pfsense, when LAN4 is the tagged port? – NickW Mar 6 '13 at 13:03

Hmm, since the two subnets are masked and cannot really communicate, I would do a NAT on both routers, then ping will work. So you have to NAT the networks.

| improve this answer | |

What happens if you set your laptop up on the middle subnet with IP: and set your gateway to the Draytek? Try to ping the Draytek ( then try to ping the subnet behind the Draytek? If you have the same problem from the laptop you can focus on the draytek. Like wise you could try pinging the laptop from the pfsense and the pfsense subnet.

I know that's not an answer but logical step to determine if the draytek is playing up/misconfigured or the pfsense is the issue.

I seem to remember a similar issue with 2 Drayteks. I think I ended doing a workaround by setting up an IPSec VPN tunnel between the 2 which adds the static routes to each device based on the IPSec config page entries.

| improve this answer | |
  • I'll try this first thing in the morning when I'm back in front of the routers. The problem with IPSec is that we wanted to connect multiple VPN tunnels to the pfsense and route to the draytek to prevent the draytek from having to use it's resources decrypting tunnels. I think multiple tunnels routed over one final IPSec tunnel would be lower performance than what we have now. – dannymcc Mar 5 '13 at 18:11
  • If I connect to the network I can ping the Draytek but not the PFsense. – dannymcc Mar 6 '13 at 11:33
  • Strangely, if I am on the subnet (on the draytek) I can ping the pfsense ( but not the draytek ( – dannymcc Mar 6 '13 at 11:35
  • I've added a diagram of how the two routers are connected. – dannymcc Mar 6 '13 at 11:45
  • On the Draytek, have you checked "System Maintenance>Management" to ensure that "Disable Ping from the Internet" is not checked? – SysAdman Mar 7 '13 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.