1

Here is my problem:

We have a virtual machine on VMware ESXi with CentOS 6.3 system (devserver). We use port forwarding to access ports on the virtual machine.

We deploy our application in tomcat on the devserver (Tomcat7,JDK7)

Iptables is disabled.

After deployment, ActiveMQ start to listen on 60001 port. The application on 8080 works fine:

  1. we can access it from another VM in ESXi subnet, using port 8080
  2. and from internet we can access it on port 8585, which is forwarded to port 8080 on the devserver
  3. our client tries to listen on 60001 for ActiveMQ broker, but that port is closed!

When I check port 60001 with nmap on localhost and on 127.0.0.1, it is open:

nmap -v -sV localhost -p 60001
60001/tcp open  activemq Apache ActiveMQ

And when I try to access it using the external IP, it is closed:

nmap -v -sV 192.168.11.105 -p 60001
60001/tcp closed unknown

netstat -an | grep 60001
tcp        0      0 ::ffff:127.0.0.1:60001      :::*                        LISTEN

service iptables status
Firewall is not running.

Where do I start searching for the solution?...

1

I don't know ActiveMQ, but from netstat you can see, that it listens only on localhost: "127.0.0.1:60001". Try to check documentation about listening IP .There is similar question on stackoverflow

  • So, is it application problem, and not system configuration? – Artyom Chernetsov Mar 7 '13 at 9:31
  • Yes, application says which IP and port need. As I wrote, I don't know Active MQ - in documentation is something about XML config file with transportConnector options – stderr Mar 7 '13 at 13:40
  • 1
    Yes, it was ActiveMQ Broker configuration: localhost:60001 -> 0.0.0.0:60001 – Artyom Chernetsov Mar 7 '13 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.