1

I have a virtual network on Azure, without a cloud service, and am attempting to create a DNS on the first node as advised in this article:

Setting up DNS within an Azure Virtual Network

The DNS server is working. The clients can lookup the name of the DNS server (the only A record), and the DNS server is forwarding non-authoritative domains to other servers. The forward and backward lookup zones work.

However, the DNS server is not creating entries for the clients, so the clients cannot reference each other by name. I have tried:

  • Verifying that the DNS server's forward lookup zone accepts nonsecure dynamic updates.
  • Setting aggressive (hourly) scavenging.
  • Verifying that the clients, and domain server are all set to a .local DNS suffix.
  • Verifying that the clients IpV4 DNS settings are set to register with DNS and use this machine's suffix.
  • Typing ipconfig /flushdns and /registerdns a lot.
  • Setting 10.0.0.4 as the DNS server in the Azure config
  • Verifying that the first node/DNS Server is 10.0.0.4
  • Verifying that the clients can communicate with each other via IP (they can communicate with the name server by name and IP)
  • I have not set up an endpoint for the DNS server, figuring that it should only be reached on the virtual LAN.
  • I have turned on packet logging.

I think there is something obvious that I am doing wrong?

If it helps, when I do an ipconfig /registerdns from one of the clients (ptcunivtqa1.local), I get the following two lines in the packet log file of the DNS server:

3/9/2013 8:50:50 PM 04F4 PACKET  0000000002229BA0 UDP Rcv 10.0.0.5        06a0   Q [0001   D   NOERROR] SOA    (11)PTCUnivTQA1(5)local(0)
3/9/2013 8:50:50 PM 04F4 PACKET  0000000002229BA0 UDP Snd 10.0.0.5        06a0 R Q [8385 A DR NXDOMAIN] SOA    (11)PTCUnivTQA1(5)local(0)
0

I have the answer.

The DNS server did not like having local, or any root domain without a dot. I switched it to ptcu.local, and it worked.

-->Adam

  • you should avoid .local. Theres a question that explains why, I don't know where it is off the top of my head – JamesRyan Mar 11 '13 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.