PROBLEM: When I minimize a remote desktop session and restore it, the remote desktop screen shows up black. This only happens when connecting to a particular computer.

DETAILS: If I start clicking around in the black area, portions of the screen will start redrawing and showing up correctly. For example, if I leave a window open in the remote session and click where that window is located on the remote computer, then that window--and only that window--will redraw, and sometimes a portion of that window won't redraw (usually the toolbar).

And to clarify--the window only has to be minimized momentarily, so it doesn't seem to be a timeout issue. Clicking or typing in the remote session still causes the remote computer to respond appropriately. Disconnecting from the session and reconnecting restores the whole screen image, as does clicking all over the place in the black image (causing each section to redraw).

CONFIGURATION: This problem only happens for me when connecting to a particular computer (a W2K Server box configured to allow remote administration) and only with certain client computers. I've tried 7 different client computers with various versions of Remote Desktop (the OSes were: Win2K, Server 2003, Server 2008, Windows 7 RC, 3 XP) and two of them exhibit the problem (one is one of the XP boxes and the other is Windows 7). Those same computers can RDP to other computers without problem.

RESOLUTION ATTEMPTS: I have tried the following:

  • Disable the LOCAL screen saver as mentioned on Technet
  • Turned off bitmap caching in the client, as mentioned on many forums.
  • Updated to version 6.1 of the remote desktop client
  • Using mRemote (I doubted this would work since it uses MS's code for connecting to RDP servers)
  • Turning off all video acceleration.

QUESTION: Any ideas on what is causing this?

6 Answers 6


Solved the problem of RDP not coming back from the minimised position. It is because when minimised RDP may not redraw the gui.

The following registry change seems to have resolved the issue (XP SP3 32k).

HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client\ Created a new DWORD value and named it RemoteDesktop_SuppressWhenMinimized. Specified 2 as the value data.


Just change the Color depth of the remote session to 24bit or less. ( You can find "color depth" setting on Display tab of the Remote Desktop Connection properties)

good luck.

  • 1
    Just a suggestion it's sometimes nice to give a bit. Ore information about what's going on and why your suggested answer is correct. Commented Dec 1, 2013 at 13:23
  • 1
    This solution works, but if you'd rather stick with full 32-bit color, you can disable Experience->DesktopComposition instead. makes your theme non-Windows-Aero, but still better than having to reconnect after minimizing....
    – Ross Aiken
    Commented Feb 24, 2014 at 17:58
  • +1 Both of these suggestions (24-bit or disabling Experience->Desktop Composition) individually resolve the issue on local LAN between Windows 7 machines, so I opted for the latter to keep the visual quality.
    – mrjoltcola
    Commented Nov 21, 2014 at 3:15

I would try updating the video driver on the Win2000 box. From this MS article - http://msdn.microsoft.com/en-us/library/aa383015%28VS.85%29.aspx

"On the server, RDP uses its own video driver to render display output by constructing the rendering information into network packets by using RDP protocol and sending them over the network to the client."

  • I am unaware of how you can update the RDP video driver (as opposed to the normal video driver). If anyone has any pointers to that info, it would be appreciated.
    – TorgoGuy
    Commented Aug 31, 2009 at 14:02
  • No I meant updating the video driver for whatever video card is in the Win2000 box - the "normal" one. The article says that RDP uses its own video driver, meaning the video driver in device manager for the display adapter.
    – August
    Commented Aug 31, 2009 at 17:00

It's not an answer, but I'm having that problem too. Local RDP sessions work fine, vpn+rdp work fine as long as I don't minimize. Server is a 2000 server, client is a win7 RC. A disco and a reconn fix the problem till I minimize again.

Same router/cable modem/vpn settings when booted into XP on the same machine = it works. Linux rdp sessions work as well. I'd guess it's something to with how windows treats inactive programs.


I had this issue several times. I found it happening only when there is latency on my network or VPN connections.

  • That's not the case here (the two computers are on the same switch), but thanks for trying! :-)
    – TorgoGuy
    Commented Aug 31, 2009 at 14:04

It could also be a bug in the video card driver, when I place the MSTSC window on a monitor connected to my AMD Radeon core display, it has this problem. However, when I moved the window to a monitor connected to an NVIDIA RTX 4070 GPU, the issue disappeared.

Upon further investigation, I found that this issue only occurs on monitors connected with AMD Radeon core graphics, so I believe this is a graphics driver bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .