1

I have a CentOS 6.3 machine. I'm running yum update but it doesn't show any updated package. I have already tried yum clean all and yum clean expire-cache. Any help will be really appreciated.

[root@www1 yum.repos.d]# yum list update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.xmission.com
 * epel: fedora-epel.mirror.lstn.net
 * extras: mirrors.xmission.com
 * updates: mirrors.xmission.com
Error: No matching Packages to list

P.S. I have epel installed as well, and I was playing with that while ago. I'm thinking that I might screw up something that day, probably ...

P.P.S. I've also tried to use baseurl instead of mirrorlist, again no success at all ...

Update

I had this line in my yum.conf which was supposed to keep the postfix package for manual updates. I just comment that out and everything seems fine now. Could anybody explain why?

exclude=postfix*

Answer

I was trying to do yum list update which was wrong! I should write updates not update. Actually the yum update works well, however I thought if yum list update is not working, then yum update will not work as well.

2

Error: No matching Packages to list

It means that there is no package named... "update". The right command is:

yum list updates

man yum:

LIST OPTIONS
       The  following are the ways which you can invoke yum in list mode.  
    Note that all list commands include information on the version of the package.    

       yum list updates [glob_exp1] [...]
              List all packages with updates available in the yum repositories.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.