I've never changed public dns records before, I'm not really sure if this is normal because of DNS cache or if It's a real problem so I need your help.

8 hours after I changed the A record of the domain in mi registrant control panel, Mi browser sometimes still opens the old site. I've checked with nslookup, using mi provider DNS servers for querys, and while sometimes it returns the correct new IP in some others it returns the IP of the old server.

Is this normal, or it's due to some misconfiguration?

EDIT: By the way I've not just changed the records, before that I changed the DNS servers, previously had them with another hosting and now I'm using the ones of the registrant.

this is my current zone configuration (Not the real IP)

mydomain.com    A   -
mydomain.com    MX  1   aspmx.l.google.com
mydomain.com    MX  5   alt1.aspmx.l.google.com
mydomain.com    MX  5   alt2.aspmx.l.google.com
mydomain.com    MX  10  aspmx3.googlemail.com
mydomain.com    MX  10  aspmx2.googlemail.com
mydomain.com    TXT -   v=spf1 redirect=spf.dondominio.com
*.mydomain.com  CNAME   -   mydomain.com
bbdd.mydomain.com   CNAME   -   bbddsrv5.dondominio.com
ftp.mydomain.com    CNAME   -   hostingsrv5.dondominio.com
imap.mydomain.com   CNAME   -   mailsrv4.dondominio.com
mail.mydomain.com   CNAME   -   mailsrv4.dondominio.com
pop.mydomain.com    CNAME   -   mailsrv4.dondominio.com
pop3.mydomain.com   CNAME   -   mailsrv4.dondominio.com
smtp.mydomain.com   CNAME   -   mailsrv4.dondominio.com
webmail.mydomain.com    CNAME   -   mailsrv4.dondominio.com
www.mydomain.com    CNAME   -   mydomain.com
  • Can you provide some more info? Like the domain, at least? old and new configurations? – fboaventura Mar 11 '13 at 20:20
  • I've added my current zone config. I didn't had one before, because I previously had a shared hosting and didn't had access to that settings. Now I've changed to a VPS and had to setup the DNS records by myself. – eleonzx Mar 11 '13 at 21:21
  • sorry, but it's pretty hard to troubleshoot without your proper domain. You have to check if your and servers are propagating the same info. How long since the change and if this time is already beyond the cache defined in your SOA. If the servers you are querying are free of cache. And some other checks may be also needed. – fboaventura Mar 11 '13 at 21:59
  • I can't expose the domain name here, client issues. I appreciate your help anyway. As of now I changed mi network configuration to use google DNS servers, and I don't have the issue anymore, so It's probably a cache value somewhere related to my ISP. – eleonzx Mar 12 '13 at 10:00

Windows? Linux? Have you tried another computer? If Windows, try clearing your browser cache, and run ipconfig /flushdns in the command prompt. It could all be cached content.

  • I have windows and tried in another device, but could that have something to do with the nslookup results? AFAIK the nslookup doesn't involve the local PC cache. – eleonzx Mar 11 '13 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.