8

I am trying to install Gearman on my Ubuntu 12.04 machine by following command

sudo apt-get install gearman-job-server libgearman-dev 
sudo apt-get install php-pear php5-dev 

Above commands run properly but when I run

sudo pecl install gearman 

it is giving errors as follows

checking whether to enable gearman support... yes, shared
found in /usr
checking for gearman_client_set_context in -lgearman... yes
checking for gearman_worker_set_server_option in -lgearman... yes
checking for gearman_job_error in -lgearman... no
configure: error: libgearman version 1.1.0 or later required
ERROR: `/tmp/pear/temp/gearman/configure' failed

I am not able to find how to install it.

3

In your repository there is old version of gearman. You need do download source of the latest version (at least 1.1.0)from http://www.gearman.org/ compile and install it. Then installation php module with pecl will go smoothly. I had similar problem on centos.

3
  • I downloaded gearmand from launchpad.net/gearmand and ./configure it but it is giving error as "configure: error: cannot find Boost headers version >= 1.39.0"
    – PankajK
    Mar 13 '13 at 9:05
  • You need to install some additional software needed in compilation proccess linux headers gcc ... etc. On centos I install this software to make compilation gearman succesful : gcc gcc-c++ mysql mysql-devel boost-devel libevent libevent-devel
    – B14D3
    Mar 13 '13 at 9:19
  • Thank you, I installed new version of gearman 1.1.5 with its dependancies and installed php module and worked perfectly.
    – PankajK
    Mar 14 '13 at 9:28
11

Another option is to install libgearman-dev from the gearman PPA:

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:gearman-developers/ppa
sudo apt-get update

Assuming you've already installed libgearman-dev and gearman-job-server, all you have to do is:

sudo apt-get upgrade

To upgrade gearman, then simply run pecl again and it should work this time:

sudo pecl install gearman
1
3

You can try installing an older version of gearman pecl extension. For e.g. latest version on Ubuntu 12.10 install failed. However, specifying bit earlier version worked fine:

pecl install gearman-1.0.3

You can find list of available versions on http://pecl.php.net/package/gearman

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.