I am trying to configure a Dell PowerConnect 6224 Switch managed switch.
The documentation for setup can be found here.

However I am unable to connect via serial port to the switch.

I do not have access to a laptop with a serial port and Windows 2000 as suggested in the documentation. However, I do have a normal laptop and a Dell PowerEdge 815 with a serial port (I think, the cable fits at least.) I have two cables that came with the switch one is a serial port to ethernet cable and the other is a serial port to serial port. I have tried using the serial to ether net cable with my laptop running Ubunutu and the serial to serial with the PowerEdge running CentOS 6.2. I tried the terminal emulators Minicom and Screen on both systems. For all of these cases when I restart the switch as listed in the documentation I get no response from the switch. Just a blank terminal screen.

I have checked the lights on the switch which seem to indicate it is running without errors. Also since this occurs with both cables I doubt this is a cable error.

Does anyone have any suggestions about how to troubleshoot this connectivity problem?

1 Answer 1


Some things to check:

  • There are two polarities for serial cables, 'null modem' and... not null modem. Null modem cables cross the TX and RX lines, somewhat like a crossover Ethernet cable. Make sure you've got the right type for the switch (if it came with it, this probably is okay, the PC side is always wired the same)
  • It's not going to work with the RJ45 cable, that's a Cisco-ism, and it's still just serial on the RJ45 connector, so you can't plug it into an Ethernet port and expect it to work
  • Are you sure the switch's serial interface itself actually works?
  • Are you sure your settings in minicom are correct? Servers sometimes have multiple serial ports, baud settings etc. and the minicom defaults aren't always sane (using linked devices like /dev/modem, for example) You can access this in minicom by Ctrl-A then O and going to serial port setup. Particularly make sure flow control is disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.