I have set up my Amazon EC2 Web server where I host my website. However, I currently access it with the elastic IP.

What I have done so far:

  • I have created a hosted zone for mydomain.com and added some record sets (following some tutorial on the internet)
  • I entered the name servers from my hosted zone into my domain registrar's DNS panel.

Currently I get a 404 error saying that it does not find the bucket. Now, I had a bucket on s3 before, but deleted it because my actual goal was to host a website. So what should I do to access the website via the mydomain.com telling it to use the elastic IP ?


It sounds like all you need to do is create an A record for mydomain.com that points to the IP address of the Elastic IP.

If you've already done that then it might be that the new address just hasn't propagated through the DNS yet and it is still pointing to the old address.

You can look up the DNS for your domain here: http://mxtoolbox.com/DNSLookup.aspx It will tell you what the A record looks like to the rest of the world.

Note the TTL (Time To Live) setting. This is the number of seconds a client will wait before asking for the address again. You'll need to wait at least that many seconds (and possibly longer) before the change will appear.

  • Yeah that is what I read on the internet but I was kind of confused with Amazon's Route 53 Service which I also set up and then I entered the nameservers in my domain registrars panel, which eventually disabled the DNS console. I then just parked my domain and now added an A record and everything works fine now. Thanks for your answer – the_critic Mar 19 '13 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.