I have a NAS, the unit became unresponsive so after some research I pulled the drives out of the box, and hooked them up to my Ubuntu box. I now see all 4 drives, and all 4 partitions on the drives. Partition 4 is a RAID 5 array so I used mdadm --assemble /dev/md0 /dev/sdi4 /dev/sdj4 /dev/sdk4 /dev/sdl4 and now it shows md0 as active.

However, this NAS also uses LVM and when I run vgscan, it says "No volume groups found"

I'm stuck, because I cant mount /dev/md0 due to the LVM. Any ideas on what to try next?

Was thinking vgcreate but I think that will blow away the data.

Any ideas are much appreciated!!

I think I got lucky, but here is what I did and it worked:

mdadm --assemble /dev/md0 /dev/sde4 /dev/sdf4 /dev/sdg4 /dev/sdh4
[no volume groups found]
vgcreate DATA /dev/md0 (just created a dummy volume group)
vgchange -a y
[0 active]
lvcreate -L5.45T -n lvo DATA (created a new lv, same size as the original)
[look for /dev/dm-* entries]
file -s /dev/dm-0
mkdir /mnt/raid
mount -t ext3 /dev/dm-0 /mnt/raid
Boom, data was there...

  • 2
    Tried pvscan? – poige Mar 16 '13 at 20:11
  • Huhh, that works sure, but I would not refer to that as best practice. – cstamas Mar 18 '13 at 11:47



and tell us about the results.

vgchange -ay

should activate volume groups in normal circumstances.

All commands are harmless. They will not touch or alter your data.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.