0

We have just recently been doing an extensive testing of a certain in-house program (called SPARE) for handling spareparts. The idea is quite simple. Each node has a database on a server and through a replication service all databases are up to date on each node. For several days we didn't get the communication to work. The logs indicated that the nodes tried to communicate but didn't find or accept incomming packages. A run with Wireshark showed that packages indeed WAS exchanged between the nodes but for some reason, SPARE didn't want to acknowledge them. SPARE uses port 7777.

We were on the phone with the developers and they thought it might be a firewall problem. However, the service that SPARE uses was in the list of exeptions and as said, Wireshark did detect packages on port 7777 in both directions.

Then we tried one last thing. We went to the advanced tab in Windows Firewall. There we went to Settings under Network Connection Settings and added the current node server IP and port 7777 and after that it all worked. Replication between the database nodes was working as intended.

For me this is a bit strange since I thought a firewall either allows or blocks all traffic on a certain port or service. But in our case it seems like it blocked only parts of it. Enough packages were passed for Wireshark to detect them but too few for letting SPARE exchange information.

Any good answers to this issue?

1

This is "working as intended": Wireshark grabs the packets before the firewall does its processing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.