1

These are the steps I took:

  1. Deploy Ubuntu EC2 instance (tried both LTS and latest) default kernel and RAM ID
  2. Snapshot Instance
  3. Create AMI from snapshot, default kernel and RAM ID
  4. Launch EC2 from AMI snapshot

I left everything untouched apart from simply the name in each of these. Then my created instance gives this:

0/2 checks passed

Can anyone shed any light on this, I really don't want to have to use another distro if I can help it.

  • 2
    Have you tried right-clicking on the original instance in the console and creating an AMI that way, rather than trying to make an AMI from the snapshot? – ceejayoz Mar 20 '13 at 12:36
  • Oh, would you believe it, that works! If you add it as an answer i'll award it. – James Willson Mar 20 '13 at 13:40
  • Glad that worked! :-) – ceejayoz Mar 20 '13 at 13:50
1

Right-click on the instance, select "Create AMI", and it should do all of the appropriate steps for you. Easier, faster, and less problematic than trying to make an AMI off a snapshot.

  • Thank you. I don't understand why this is any different but it seems to work fine. – James Willson Mar 20 '13 at 13:59
1

Don't use the default kernel/ramdisk (AKI/ARI).

When you register a snapshot as an AMI, be sure to specify the same kernel and ramdisk as were used by the original AMI and instance.

This is what the "Create AMI" function does (and the ec2-create-image command line tool).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.