0

We currently have three Belkin routers which we use as access points... they each have a static IP setup in the "use as access point" page in the 128 range and work great. (I just took over this position, don't ask me why they used 128 range). Anyways, we ordered two new Belkin routers and every time I go to assign a static IP of 128.0.0.x I get an error of "Invalid IP Address." I have already tried upgrading firmware... still same error.

Anyone else encounter this? The new router is Play N600 Model F7D8302 v1.

What I am assuming is the engineers or someone decided that they should no longer allow the class B range as an acceptable IP. I have escalated a case to a Belkin engineer.

Curious if anyone else has had the same problem.

Thanks!

4
  • 1
    It's a horrible idea to be stealing someone's IP address space which you clearly don't own; also, these (or any?) Belkin routers have nothing to do with server-grade matters, which is what serverfault is about. – cnst Mar 21 '13 at 0:51
  • Not to mention that using other people's IP addresses is considered abuse, and is a great way to get your ISP to cancel your service, have federal agents show up at your business, etc. You should renumber the internal network ASAP. – Michael Hampton Mar 21 '13 at 1:01
  • Whoever started using 128.X did you a very serious disfavor. That would not cause your trouble as the router would not know you aren't the true owner (I looked it up, there is a true owner). But it will cause other troubles so you should plan to change things soon. More config details are needed to determine the cause of the "Invalid IP address", such as subnet/CIDR mismatches. If the subnet is 128.0.1.0/24 then 128.0.0.X won't work. Same for 128.0.0.0/28 for 240 of the possible legal valus for X. – Skaperen Mar 21 '13 at 1:01
  • If the use of other people's address is confined to your own LAN and gets translated via NAT to your real assignment on the way out, your use of these wrong IPs won't be seen. But you won't be able to reach those IPs at the real owner's network. It only hurts you and your users. But you should renumber, anyway. Either use the IPs you are assigned (no NAT) or use private IPs from RFC1918 (link in answer below) with NAT. – Skaperen Mar 21 '13 at 1:04
3

I can't say why the router won't let you configure that, but I can tell you that you really shouldn't be using the 128.0.0.0/24. You should be using an RFC1918 IP range. By using the 128.0.0.0/24, which is a valid address on the Internet, you cannot access any Internet hosts that use those IPs.

1
  • Addresses in the 128 range were commonly assigned to large universities, and most still are assigned to them. Such a misconfiguration makes traffic to and from these sites impossible. – Michael Hampton Mar 21 '13 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.