2

I have a Windows 2012 server that is running SQL and therefore doesn't have any internet connectivity at all (only access to the domain network). I have it configured to receive updates via a WSUS server on our local network. I am getting numerous warnings in the event log for this server under the source of DeviceSetupManager with the following details:

  • A connection to the Windows Update service could not be established. (ID: 200)
  • The Network List Manager reports no connectivity to the internet. (ID: 202)

Can I simply disable the "Device Setup Manager" in services to prevent these warnings? I worry because in the description for this service it states "If this service is disabled, devices may be configured with outdated software, and may not work correctly". Has anyone else disabled this service and if so, did you encounter any issues? Or if I should keep this service enabled, is there some configuration I am missing for a computer not connected to the internet? FYI, normal Windows Updates on this server work as expected by checking our WSUS server.

5
+50

Device Setup Manager just goes out and pings windows update every night to see if any devices that are installed and set up to use windows up date to update drivers.

Since this is an internal server there probably aren't too many devices attached to it who's drivers update frequently. It shouldn't matter too much to disable it, so long as you have the drivers up to date.

I would be a little concerned that it can't connect to WSUS, WSUS should bring down hardware updates too if you tell it to. Maybe if WSUS is a version previous to 2012 the DriverSetupManager service doesn't play nice.

  • Thanks for the information (and sorry for the delay). One clarification, the system CAN connect to our WSUS server. It is a 2008 version though, so I'll see if that has any effect on it. – bigmac Apr 3 '13 at 21:13
1

1.Start Local Group Policy Object Editor. Click Start , and then in the Start Search box, type mmc gpedit.msc.

2.If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Yes .

3.Open Local Computer Policy , Computer Configuration , Administrative Templates , System , Internet Communication Management , and then Internet Communication Settings .

4.In the right-hand pane, double-click Turn off Windows Update device driver searching .

5.Select Enabled to prevent Windows from searching Windows Update.

0

Disable automatic updates altogether.

  • And leave the server without critical patches and updates? I think his better of finding the root cause of the problem in this case. – bonga86 Apr 2 '13 at 20:37
  • The server has no internet connectivity. That is the root cause. – Eirik Toft Apr 2 '13 at 21:25
  • 1
    @bonga86 You really shouldn't allow production servers to automatically update. You need to test the patches before rolling them out and systematically deploy them so you can have the servers imaged, data backed up, and stakeholders notified of an outage and in case of a failure. – Snowburnt Apr 3 '13 at 14:51
  • Thanks Snow, maybe I didn't understand the question correctly. We definitely test before deployment, when you say 'shouldn't allow production servers to automatically update' do you mean all updates must be installed manually on servers? We have an OU with our test servers we first deploy updates too and test the update, when satisfied we approve it for our live systems. The install on the live systems is automatic as were already satisfied with the patch/update, so should this step be done manually? Thanks – bonga86 Apr 6 '13 at 8:19
  • This answer is way out of date and way too sparse. While justified in the comments, the pertinent information supporting this recommendation needs to be in the answer itself. Also, manual updating of every server is a bit old-school way of thinking. On an enterprise level it might still make sense if one of your application owners insists upon a dedicated maintenance window for updates, but that should be the exception and not the rule. – Thomas Nov 8 at 23:38
0

I would recommend you disabling the log of the device manager. This is exactly one of those things which you'll forget to enable once your server gets internet connection. Furthermore no ones seams to be sure how the device manager service interacts with WSUS?

Run on CMD:

wevtutil sl "Microsoft-Windows-DeviceSetupManager/Admin" /e:false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.