I'm looking for the easiest and most sane way of installing the latest version of apache (currently 2.4.4) and PHP (currently 5.4.13) on CENTOS 6.4 (x64) and I've run into no end of issues.
If I use yum with the default repositories the latest version available is 2.2.15 (which seems to have been released Mar 2010) 3 years ago. Really? I want a three year old web server on my brand new server?
So I next looked at building from source - which I was able to do but when I finished installing I wanted to test uninstalling so I did a "make uninstall" and was greeted with a message make: *** No rule to make target `uninstall'.
Great so I can't uninstall it in an automated manner to upgrade later on? Additionally when I went to build PHP from source I was faced with dependency after dependency. I proceeded with installing one by one until I eventually gave up. This doesn't seem like a reasonable approach - no option to uninstall - never-ending dependencies.
I next looked at alternative repositories like REMI - it seems REMI offers PHP5.4.13 it requires apache 2.2.15 You'll get a message stating Requires: httpd-mmn = 20051115 (which is apparently part of Apache 2.2.15
I next looked at building my own RPM from source. (At least that way I could easily uninstall them.) That worked fairly well - initially. I was able to easily build an RPM of apache, and with a little effort I was able to tweak PHP to look for apache 2.4.13 but after I do that I'm still prompted with an error that php54 requires Requires: libcurl.so.3()(64bit). I seem to have curl and libcurl, libcurl-devel installed.
At this point I'm frustrated - there has to be an easier way to get an updated Apache and PHP stack without this craziness. How are other admins doing this? Is there some secret way of doing this that I'm not aware of? Or is everyone just running really old versions of Apache and PHP and ignoring that they're riddled with security holes?