I recently purchased a new Cisco 881W and I am trying to connect to setup the initial configuration. The last time I did this about three years ago I connected over a serial link to the console port, but I no longer have a computer with a legacy serial port available and I really can't wait for a serial to USB converter to come in the mail.

So, I tried to connect using Cisco CP Express. I got as far as the CP Express splash screen popup with a message that says "Loading Cisco CP Express... Please wait." But then another poup appears that says

Cisco CP Express Application could not be launched. If CP Express is lanuched using https try the following steps and relanuch CP Express. 1. Disable TLS option in JRE Settings. Please close all Cisco CP Express windows before proceeding.

Needless to say, I've tried diabling TLS... and I wasn't using https anyway. Is it possible to debug connecting to CP Express?

  • 2
    #1 Systems/Network Administrator rule: Thou shalt never be further than 60 seconds away from the nearest USB->Serial dongle.
    – EEAA
    Mar 25, 2013 at 2:41
  • and I really can't wait for a serial to USB converter to come in the mail. You don't live near a Microcenter or a Fry's or the like you can drive to and buy one from? Mar 25, 2013 at 12:58
  • @HopelessN00b I know of no store in this state that would have anything like that. In any case, I understand that it's important to get one with an FTDI chipset. Mar 26, 2013 at 1:36

2 Answers 2


From Cisco's docwiki page for troubleshooting CP Express:

JRE settings for Cisco CP

The following JRE settings are needed for Cisco CP to function properly:

Go to Start > Control Panel > Java.
Click View under Java Applet Runtime Settings.
Select your JRE in use.
Set the "Java runtime parameters" with the value "-Xmx256m -Dsun.java2d.d3d=false".

In addition, if JRE is upgraded to versions 1.6.0_11 or above, the following settings are needed after installing Cisco CP:

Go to Start > Control Panel > Java > Advance.
Select "Java Plug-in" tree.
Uncheck the check box for Enable next-generation Java Plug-in.
Restart Cisco CP. 
  • I can add runtime parameters but they disappear when I reopen the dialog. Also, the "Enable next-generation Java Plug-in" is checked and grayed-out. Any suggestions? Mar 25, 2013 at 13:17
  • I normally use the CLI, so I have no experience with Config Pro, sorry. However I do have about 300 console cables in my cube if that's any consolation.
    – cpt_fink
    Mar 26, 2013 at 1:16
  • In that case I'll come over to your cube to get one. Mar 26, 2013 at 1:38
  • I fixed the java installation and was able to make these changes, but they made no difference. It's hard to believe that Cisco would release configuration software that is so unusable. Mar 26, 2013 at 1:42
  • I would agree with you about the config software. If you have DHCP on your subnet and the router is completely blank, you can try plugging it into the network and then powering it on. Depending on the code loaded on the router it might pick up an address so you can telnet to it and configure it via the CLI.
    – cpt_fink
    Mar 26, 2013 at 1:59

Try running the CISCO CP express as Administrator. In my case, that worked. I had to use this workaround even though my own acount is part of the Administrators group.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.