1

From the last couple of weeks We are getting "This page is in Arabic would lyou like to translate it" at the top of the page when we load our website pages using Google chrome browser.

What could be the reason? Can we avoid this?

Please help us.

Thanks!

  • 1
    Well...is your page in Arabic? – tombull89 Mar 25 '13 at 10:08
  • No our language is "English" for all our pages. We are getting this message since last few days only. – Big Data Mar 25 '13 at 10:11
  • Chrome uses heuristics to determine language if no indication is given, you sometimes get hilarious effects like a page containing randomly generated passwords being taken for welsh... – rackandboneman Mar 25 '13 at 11:12
5

If your page is in English, you could trying setting the HTML lang attribute as shown:

<html lang="en">
<title>My Page</title>
[rest of page]
</html>

Replace en with the ISO 639-1 code of your choice.

Alternatively, if you want to go the Sledghammer route you can disable translation by using a Google specific meta tag:

<meta name="google" content="notranslate" />

Bear in mind that this will prevent people who don't speak English from translating, though.

  • Thank you People for your Response and Support, I'll get back for further queries. – Big Data Mar 25 '13 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.