8

Okay this is driving me NUTS.

The server will sit with a Network Status of "Unplugged" for ages until it is rebooted. This seems to occur at random times (2am, 10pm, 8:30am, 3pm etc) it does once every 24-48 hours or so. Environment is a small business with 6 workstations and 1 large Sharp Printer.

  • Win 2008 SBS 64bit
  • There are no scheduled tasks that I can link to it.
  • Dell Poweredge 2900 with Dual Broadcom BCM5708C NICs (Only one in use)
  • Drivers are up to date per Dell's Site
  • The Cables ARE plugged in.
  • The Cable has been replaced twice.
  • The entire switch this server is hooked up to has been replaced.
  • The router has been replaced recently.
  • For every instance I have noted it being down I can find no correlations in the event log.
  • Have turned off Auto-Negotiate and tried several settings.
  • The NIC that has never been used has been swapped into active duty (same IP and everything) as the other, the first one was then disabled.
  • I do see some LAN RX errors listed in the router (about 3% they don't appear to originate from the server but I can't totally rule that out).
  • I have installed Wireshark just now and have set it to capture and save off to a log file.
  • Winsock and IP Resets, They do nothing.
  • 1. Are all the Dell/Broadcom firmware levels at the latest rev? 2. Do you ever actually lose IP connectivity? – mfinni Mar 25 '13 at 22:12
  • Yes Connectivity is fully lost. Firmware levels are up to date based on Dell's site for this product. – Dbrewer Mar 25 '13 at 23:30
  • You mention you disabled 'auto-negotiate', if the switch is still set to auto you could be causing the errors you mention to yourself... I know this doesn't answer the main question, but it could help clean up some extraneous error messages. Also, can you check on the switch to see what it is reporting? – cpt_fink Mar 26 '13 at 1:12
  • 1
    What happens when you disable media sense (netsh int ipv4 set glob dhcpmediasense=disabled; netsh int ipv6 set glob dhcpmediasense=disabled; netsh int ipv4 set glob mediasenseeventlog=enabled; netsh int ipv6 set glob mediasenseeventlog=enabled)? Did you have any third part software on server that can interact with network (antivirus/firewall/vpn/etc.)? Did you can correlate any change with start of this issue? – dsznajder Mar 26 '13 at 7:41
  • 1
    When the cable is marked as unplugged are there link lights on the NIC or the switch? Have you reseated the cable while it was marked unlugged? – GerryEgan Mar 26 '13 at 21:31
1

Is power-managment disabled on the network card ?
In my experience 99 of 100 times erratic network loss is caused by Windows putting the NIC to sleep from which it never wakes up again.

Go to the connection in "Network and Sharing center". Open the properties. Then hit the configure button just under the driver of the adapter.
Disable everything related to power-management. It will be on its own tab or be an option in the advanced settings.

If you can't disable it the driver doesn't support it in the first place so it is not the cause of your problem. In that case I'm inclined to put it down on some vague interaction between the network card and the switch. Updating the NIC firmware and the drivers (if possible) might help in that case.

| improve this answer | |
0

If rebooting fixes the problem but you've tried the second NIC with the same issues I'd say its some crazy registry error causing problems. Have you recently installed new hardware to the 2900? If so just reformat.

You can try buying a PCI express NIC and using that(just to test, you might get lucky) first, but you've knocked out everything hardware wise it seems. Pretty unlikely that both NICs are going bad, even a wireshark capture might not help if its a crazy registry error. There should be no reason there isn't at least a physical link on at least one of the ports, which makes me think registry. When you start doing things that are more complicated than reformatting, just reformat.

Bet you both NICs work fine afterwards.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.