I'm trying to get UltraVNC integrated with WinPE to allow remote control over deployments in MDT 2012.

These are the steps I've taken so far.

  • Extracted winvnc.exe, vnchooks.dll to a directory that will place them into %SystemRoot%\System32 on WinPE when I update my deployment share.
  • Created a ultravnc.ini file and added that in as well.
  • Created a step to disable firewall using wpeutil disablefirewall
  • Created a step in my task sequence to start winvnc.exe
  • Rebuilt the WinPE boot images from scratch.

Now for my problem, Everything works wonderfully. When the step runs ultravnc I'm able to connect and see everything and interact with the install. However the task will not continue and stays at "Starting UltraVNC!" and will not continue. When I use winvnc.exe -install it will continue but I can't connect to the session. As a work around I can exit to command prompt, disable the firewall, and start winvnc.exe. Then restart my deployment with wpeinit. If I could just get it to continue the task sequence after starting UltraVNC is started it would be awesome.

I think it has something to do with the error codes but I'm not really sure. Any ideas?

  • What client OS? I had hellacious issues with UltraVNC on Windows 7x64 to the point that I switched to using TightVNC to avoid the problem. If I recall correctly, the issue was UltraVNC's 64 bit drivers almost worked properly. – HopelessN00b Mar 28 '13 at 15:25
  • The server is running on WinPE 3.1. I have the same problem with x86 and x64 flavors. I've tried the viewer off of WinXP, Win7x64, and Win8x64. The viewers work great, the server works great. I just can't get MDT to advance to the next step in the task sequence. :( – Hugh Mar 28 '13 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.