Ok, I'm about out of ideas here. Can anyone help me with this .Net Framework Patch? I am trying to install a KB patch (KB2756918) to a Windows Server 2003 R2 x86 box.

Edit: Just to clarify specs:
Windows Server 2003 R2 32 bit
Machines are on an isolated network
Manually installing patch (yes it is the 32 bit version)
Issue is affecting multiple boxes, but not all (Both working & nonworking boxes are identical setups)

For simpler reading I'm listing here what I've done first followed by the error I get, which incidentally, has never changed regardless of my troubleshooting steps. (ie, it fails the same way every time; I'm not even getting different error messages)

Please note this is on an isolated network

Trouble Shooting Steps: (I reboot and attempt a manual install after each troubleshooting step)

  1. I have run a repair on .Net Framework (Fails due to isolated network)
  2. I have manually uninstalled/reinstalled all versions of .Net
  3. I have manually uninstalled all .Net versions
  4. I have run the .Net removal tool on everything
  5. I have run the .Net removal tool to get down to 3.0 so I can attempt to apply this patch & then apply the remaining .Net versions

So far, Technet & Google have been unfruitful endeavors

No matter what troubleshooting step I've completed I get the same installation error: "The installation failed with: This package could not be opened..."

Event Viewer reports:

  1. ".NET Runtime Optimization Service (clr_optimization_v2.0.50727_32) - Service reached limit of transient errors. Will shut down. Last error returned from Service Manager: 0x80030002."

  2. "The description for Event ID ( 0 ) in Source ( .NET Runtime ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Shim database version (path location listed here was removed by me) doesn't have a matching runtime directory.

  • How are you getting the patch? Specifically, have you tried manually downloading it and running that, or just been re-downloading via Windows Update? (Oh, and one more stupid question... the Server you're trying to install this on is a 64 bit versions of Server 2003, right?) – HopelessN00b Mar 28 '13 at 19:29
  • Initially this was pushed using patch management software. However, now that it's not working I have manually downloaded the patch from MS. Also, not a dumb question as this is NOT a 64 bit. I will edit the question to state it IS 32bit. Thanks – Ben-Jamin Mar 28 '13 at 20:12
  • Alright, then here's the dumb question... you are downloading the 32 bit/x86 patch, right? Named: NDP30SP2-KB2756918-x86.exe – HopelessN00b Mar 28 '13 at 20:19
  • Yes, I am using the x86 patch. And I would say that is a dumb question except I completely understand your reason for asking. Thanks for checking, and in a nice, "I'm not calling you an idiot" way. – Ben-Jamin Mar 28 '13 at 20:24
  • Have you tried the .Net Framework 3.5 SP1, I assume it would include the patch you trying to install above. microsoft.com/en-za/download/details.aspx?id=25150 – bonga86 Apr 2 '13 at 20:43

When all else fails: READ THE DIRECTIONS! (yelling at myself here)

On the Microsoft website for this KB Patch: (Under Prerequisites) "To install this update, you must have Windows Installer 3.1 or a later version installed on the computer. To obtain the latest version of Windows Installer..."

I can't even begin to tell you how much time/effort we spent on this problem. And why on earth MS doesn't give you an error message that identifies an "outdated" MS Installer version is beyond me.
We originally dismissed the Installer as the culprit because all other patches were installing fine. To compound our confusion, was that multiple servers of identical build (which were supposedly identical in all ways) were split..some would take the patch and others would not. For some reason this one particular patch/upgrade didn't apply to these select few servers. Once we upgraded the installer everything worked like a champ!

So anyone having this or similar issues in the future, Check the prereqs and make sure you have the correct version of the MS installer.

Go into cmd prompt or the run dialog (Windows + R) and execute msiexec -?

| improve this answer | |

You need to wipe it completely out and start fresh with the entire framework. I know, painfully long downloads/installs await you, but it will get the job done.



Here's where it's from:


Run it and remove it all. Let it do it's thing, then reboot. Once you'e back in, proceed to reinstall the whole shabang, starting from 1.0/1.1 and up. I would just install up to 4.5, then recheck if the patch is still needed.


Good luck!

EDIT: If you are reinstalling dotnet from cached copies somewhere, perhaps they are corrupt. Get a fresh copy from the microsoft link and try it out.

| improve this answer | |
  • I have already attempted these steps listed as 4 & 5 above. I didn't state it, but I did download a fresh copy of the KB just to make sure it wasn't corrupt. – Ben-Jamin Apr 5 '13 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.