0

I have just updated from 8.04 to 10.04 after such a long time I am rather excited. But since the update I am now unable to login to my server via WinSCP but a connection with PuTTY is still completely fine.

Neither are using private keys. I am just entering a username and password each time.

I do however get through to the authentication panel, where i can enter my username and password. This is where it appears to time out.

So, is there a reason why one would accept a SSH connection and not the other?

0

3 Answers 3

1

There was such a bug in WinSCP before 5.0.5 version (https://winscp.net/tracker/764) and relevant discussion here (https://winscp.net/forum/viewtopic.php?t=10266). So please check what version of WinSCP you are using. Try upgrading or downgrading to either 4.3.5 or 5.0.5 as they have no this bug.

1
  • I updated to the latest version and now indeed its all working as expected :D Apr 4, 2013 at 22:57
1

I observed the same issue after upgrading to Ubuntu 22.04 with WinSCP 5.19.6

Adding the following lines to the server's /etc/ssh/sshd_config fixed it for me

PubkeyAuthentication yes
PubkeyAcceptedKeyTypes=+ssh-rsa 
1
0

I had "sudo su -c /usr/lib/openssh/sftp-server" in WinSCP config in advanced -> SFTP Server. Changed it back to default and I am able to connect again. Need to do some permission management I guess since this problem started only after I turned off remote root login and started to use different user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.