0

i have a computer that has windows xp

i install cvsnt on it and i create a repository in c:\test_repository

i connected to it locally import a program to it updating and committing it

every thing work fine

now i want to access this repo. from another computer on the network

i used the pserver method

i tried first to access it locally

when i tried CVS -d :pserver:amir:123456@192.168.1.111:/test_repository init

192.168.1.111 is the ip of my server and amir and 123456 the username and the password

it returned error cvs [server aborted]: Protocol error: Root request missing

i tried CVS -d :pserver:amir:123456@192.168.1.111:C:/test_repository init

it returned error cvs [init aborted]: C:/test_repository: no such repository

i tried to set home=C: or Root=c: but the same error happened

what is the solution here please?

  • The command you are trying to execute, "init", doesn't work remotedly. – Krist van Besien Apr 2 '13 at 9:57
0

The command you are trying to execute, init, needs local access.

To initialise your repository you need to do something like this:

cvs -d c:/test_repository init

This will initialise your repository, and you can then access it remotedly (if properly configured...)

  • great i did it i do the initialization locally but now how can i access this repository from the another computer? – امير طارق Apr 2 '13 at 10:17
  • i tried to import locally and then i tried to check out online it take alooooooooooot of time with no answer i tried to shaqre the folder over the network and try again but no difference – امير طارق Apr 2 '13 at 10:43
  • I would try in this oder: First make sure everything works locally. Then try to use remote commands from your local machine. Then try from another machine. It might be that your ssh daemon is not properly configure, that it is not started, that a firewall is in the way etc... – Krist van Besien Apr 2 '13 at 15:13
  • every thing work locally when i call remote command from local machine it never work and go infinity i use pserver not ssh – امير طارق Apr 3 '13 at 5:55
  • when i tried ssh using freessh.exe it connected to it and i can see it as online network user on freessh but return nothing for me – امير طارق Apr 3 '13 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.