1

I'm having a problem doing a yum update with php and it's having a dependency problem with libjpeg.so

here is the yum update output:

yum update
Resolving Dependencies
--> Running transaction check
---> Package php54w.i386 0:5.4.12-1.w6 will be updated
---> Package php54w.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-bcmath.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-bcmath.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-cli.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-cli.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-common.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-common.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-devel.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-devel.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-gd.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-gd.i386 0:5.4.13-1.w6 will be an update
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: php54w-gd-5.4.13-1.w6.i386
---> Package php54w-mbstring.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-mbstring.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-mcrypt.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-mcrypt.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-mysql.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-mysql.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-pdo.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-pdo.i386 0:5.4.13-1.w6 will be an update
---> Package php54w-xml.i386 0:5.4.12-1.w6 will be updated
---> Package php54w-xml.i386 0:5.4.13-1.w6 will be an update
--> Finished Dependency Resolution
Error: Package: php54w-gd-5.4.13-1.w6.i386 (webtatic) Requires: libjpeg.so.62(LIBJPEG_6.2)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
php54w-mcrypt-5.4.12-1.w6.i386 has installed conflicts php-mcrypt = ('0', '5.4.12', '1.w6'): php54w-mcrypt-5.4.12-1.w6.i386

I did a locate libjpeg and it finds it:

locate libjpeg
/usr/lib/libjpeg.so
/usr/lib/libjpeg.so.62

Has anyone ever had this problem or know how to fix it? should I just simply do the --skip-broken and call it a day?

Thanks.

1
  • One problem appears to be that you have conflicting versions of the php mcrypt library installed. (1) php-mcrypt and (2) php54w-mcrypt. The "libjpeg.so.62(LIBJPEG_6.2)" that php54w-gd-5.4.13-1.w6.i386 requires is provided by a package named libjpeg-turbo. Is it installed?
    – ZaSter
    Apr 10 '13 at 0:32
0

CentOS 6.4 broke backwards compatibility in some library versions, and so latest Webtatic builds only support CentOS 6.4 for some packages (most of the PHP packages are unaffected).

If you can update your CentOS 6.x version to 6.4, that would solve the issue. CentOS has in recent years started making it hard to fix to earlier releases to try to push users to the latest release.

It's not an ideal situation for servers that can't be upgraded, but repositories would have to support each minor release to avoid this situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.