I recently bought used Cisco Catalyst 4948 and can't configure it : is see no link on all interfaces, serial console works but only output I only can stop autoboot and enter in rommon.

Any hints how to enable input in serial console ?

Boot stops at : http://tinypic.com/r/2920mk5/6

Maybe hardware problem ?

[Solved] It was hardware problem, no one here helped

  • Do you have a proper Cisco serial cable? See here: serverfault.com/questions/495678/… – pauska Apr 3 '13 at 10:16
  • Yes, I have RJ-45-to-DB9, I can see POST messages, interrupt booting, write rommon commands but when it boots in ios i can't send anything (hitting return N times not helping) – Jhon Apr 3 '13 at 10:58
  • Did you set your terminal parameters correcty: cisco.com/en/US/tech/tk801/tk36/… – joeqwerty Apr 3 '13 at 13:29
  • Yes, I followed rules from there – Jhon Apr 3 '13 at 13:36

Sounds to me like the previous owner may have changed the speed on "line con 0" as you initially get output but then it stops, although I do have two hangups with this thought. First, you will often get garbage characters instead, but this is not always the case.

Second is in another answer you said you are booting with the config-register of 0x2142, so any config shouldn't be applying. However maybe this is stored outside the normal config and as such still applying? I know things like the boot variables typically do this, but I would have to do some digging to recall everything that is like that.

Did you try other "standard" serial rates other than 9600 to see if it connects? Here is the list that I know of: 2400 4800 14400 19200 28800 33600 57600 115200

You may also want to try playing with the signaling and flow control as that can be changed as well. However I would start with speed, as it is semi-common for people to increase this as people often find 9600 slow. The only reason I have known people to change the other values (or use a slower speed) is to make it more difficult for people to access the console port.

  • Looks like ios is not booting : tinypic.com/r/2920mk5/6 , booting stops and nothing more shows (waited more than 30 min) – Jhon Apr 3 '13 at 17:36
  • 1
    Or this could be the point where the console's speed/flow control/signalling change. Usually IOS attempts to load multiple times or gives an indication it is corrupt, however it looks from the image that IOS has loaded. If you do think it is a bad IOS file, then try giving it a new one. You can find the image recovery procedure here: cisco.com/en/US/products/hw/switches/ps663/… – YLearn Apr 3 '13 at 18:00
  • I tried to boot via tftp with newest firmware - same result, i47.tinypic.com/9b9m3q.jpg – Jhon Apr 3 '13 at 18:08
  • Still looks to me like IOS has booted and that you lose connectivity after it boots. Still leaning towards speed/flow control/signaling. – YLearn Apr 3 '13 at 18:33
  • I will try to work with speeds but why it changes for new firmware – Jhon Apr 3 '13 at 18:45

It the switch isn't booting into IOS, there's a good chance that the flash got formatted before it was sent to you. You'll need to use TFTP to download a new IOS image onto the device.

This link will likely help.

  • Switch boots into IOS i can see on console, but can't input nothing – Jhon Apr 3 '13 at 10:23

If the switch is configured to use TACACS+ for console authentication, and if it can't reach any configured servers after booting, IOS will take a minute or two to time out before it falls back to local authentication. Until it times out, it will act as though it is unresponsive to input. I would guess this applies to RADIUS as well.

It's possible this switch still has someone else's configuration on it, so make sure you're bypassing startup-config by setting the config register to 0x2142 in ROMMON, as described in Cisco's password recovery procedure for this switch series.

  • With 0x2142 switch was online more than 40 min and no still no input in console – Jhon Apr 3 '13 at 14:53
  • That's much longer than I'd expect a TACACS+ timeout to be, so that probably isn't it, then. – James Sneeringer Apr 3 '13 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.