I've seen this error all over the place for 2012 and 8 Windows' versions. I have tried multiple methods of getting around this issue to no avail. Some methods I tried: Disk part from command prompt, reformatting and setting active and primary. Basic format within working Windows desktop. GParted format of drive and msdos partition table.

It's a sata drive connected directly to the motherboard of a Dell tower server.

It's interesting that Server installation can see the drive, format it, create a primary partition within the software installation but upon clicking Next it simply fails to continue. Install is coming from a DVD. There are no SD cards or USB drives connected and it is only listing my single SATA drive in the list. The only other thing I can think of is that I have a Perc s300 with drives attached to it; they don't show up in the list presumably because I don't have the drivers during the installation.

Why is 2012 so much more difficult to install on a drive? What am I missing?


I had to disconnect and remove the Perc RAID card (which is hardly a raid card, but what ever). Finally the installation could continue! As a side note, I tried 2008 and it reported the same issue, so it's not specific to 2012 installation. I actually removed all of the connections and then the card from the slot, physically. I'm sure there was a way to fiddle with this via software but I didn't see anything specific in the bios or perc config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.