I have a recently-deployed 1 server windows domain running Windows 2008 R2 Standard SP1 and Exchange 2010 SP3, running on the 2003 R2 domain and forest level. The server receives email through a main and backup ADSL router using port 25 (SMTP), and PopWeasel, a POP3 collector. The Exchange server is protected by Sophos PureMessage 3.1.2

The exchange server was deployed with an email size limit of 10MB (I believe that's Exchange 2010's default value) - I want to increase that to 15MB, but I'm having trouble doing this.

Using a Test email with an 11MB attachment (to allow for headers and encoding bloat), Internal to Internal email, and internal to external email is working fine.

External to internal email generates a bounce-back to the sender, the core part of which is:

[InternalServerName].local #<[InternalServerName].local #5.3.4 smtp;550 5.3.4 SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size> #SMTP#

This happens whether the email comes in the either of the two SMTP connections; it gets delivered when using the POP3 collector, but I believe as it "Originates" from the server's IP address, it's treated as an internal-internal email, which does work fine

I have gone through with Sophos Support, and they have confirmed there is no size limitations in the current PureMessage config.

Working through this Exchangepedia article, I can't see any issues in the Management console or Exchange Shell.

I've got the full dumps of the Transports available if needed (Get-TransportConfig, Get-ReceiveConnector "External Email" | Format-List, Get-SendConnector "SmartHost Connector" | Format-List, Get-ADSiteLink, and Get-mailbox | ft name, MaxSendSize, MaxReceiveSize), but here are the commands and summary reports taken from this LAN-Tech article:

Get-TransportConfig | ft name, MaxSendSize, MaxReceiveSize

Name                                    MaxSendSize                             MaxReceiveSize
----                                    -----------                             --------------
Transport Settings                      15 MB (15,728,640 bytes)                15 MB (15,728,640 bytes)

Get-ReceiveConnector | ft name, MaxMessageSize

Name                                                        MaxMessageSize
----                                                        --------------
External Email                                              15 MB (15,728,640 bytes)
Internal Email                                              15 MB (15,728,640 bytes)

Get-mailbox | ft name, MaxSendSize, MaxReceiveSize

Name                                    MaxSendSize                             MaxReceiveSize
----                                    -----------                             --------------
Administrator                           20 MB (20,971,520 bytes)                20 MB (20,971,520 bytes)
DiscoverySearchMailbox {D919BA05-46A... 100 MB (104,857,600 bytes)              100 MB (104,857,600 bytes)
Test User                               unlimited                               unlimited
User1                                   unlimited                               unlimited
User2                                   unlimited                               unlimited
User3                                   unlimited                               unlimited

I Set the Administrator to a 20MB limit, rather than the transport Hub default, but the 11MB Email fails when sent to the Administrator, the Test User, or anyone else.

I also checked the ADSIEdit settings, even though it shouldn't apply as we're not running in 2003 mixed mode:

delivContLength - 15360 submissionContLength - 15360 msExchRecipLimit - 100

Can anyone think of something I may have overlooked? I'm at a bit of a loss to explain what's blocking the email.

In reply to @TheCleaner, - Running Get-SendConnector gives my single outbound connector:

Identity                                AddressSpaces                           Enabled
--------                                -------------                           -------
SmartHost Connector                     {SMTP:*;1}                              True

Running Get-SendConnector "SmartHost Connector" | Format-List gives:

AddressSpaces                : {SMTP:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : False
DomainSecureEnabled          : False
Enabled                      : True
ErrorPolicies                : Default
ForceHELO                    : False
Fqdn                         : [External Address URL]
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : [ServerName]
Identity                     : SmartHost Connector
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 15 MB (15,728,640 bytes)
Name                         : SmartHost Connector
Port                         : 25
ProtocolLoggingLevel         : None
RequireOorg                  : False
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : [SmartHost URL]
SmartHostsString             : [SmartHost URL]
SmtpMaxMessagesPerConnection : 20
SourceIPAddress              :
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {[ServerName]}
TlsAuthLevel                 :
TlsDomain                    :
UseExternalDNSServersEnabled : False

I believe that's set right.

I tried restarting Exchange and IIS when I first worked on this last week. When that didn't make a difference, I rebooted the whole server.

Update (15/04/13)

I've applied 20MB Limits, and run Get-TransportConfig | ft name, MaxSendSize, MaxReceiveSize, Get-ReceiveConnector | ft name, MaxMessageSize, Get-mailbox | ft name, MaxSendSize, MaxReceiveSize, and Get-SendConnector "SmartHost Connector" | Format-List to confirm the Shell agrees with the console. I than Re-started the Transport service, as per Jeremy's Suggestion. That's allowing an 11MB email through now, so thanks for the help, Jeremy & TheCleaner

I find it hard to believe an 11MB email can can get bloated up by almost a third - what's the best way to get the correct size of the email when passing through exchange?

  • 1
    Two things: 1-did you also set your SendConnector size to 15MB? 2-did you restart the Exchange services? Also, because of overhead, if you want a 15MB limit I would suggest setting it to 20 everywhere to account for overhead. – TheCleaner Apr 4 '13 at 14:22
  • Thanks for the reply, @TheCleaner - Question updated with Get-SendConnector readout, and confirmed I did a full server reboot. – Dave Apr 4 '13 at 16:00
  • Hmmm...it all looks right to me. And the email gets pushed from Sophos over to your Exchange server it appears if the NDR is coming from your server. I wonder if the issue is that the email is getting bloated above the 15MB? What happens if you set everything to 20? Do you then get that test email (and can you then confirm its true size in the message tracking logs?) – TheCleaner Apr 4 '13 at 16:29
  • I'll try setting a 25MB Limit, Restarting, and testing tomorrow. Just don't tell my users ;-) – Dave Apr 5 '13 at 0:14
  • 1
    When changing your mail connectors, it's only necessary to restart MSExchangeTransport for the changes to take effect. You can do this whenever you want and your users wouldn't notice -- unless you make a change that breaks the connector ;) – Jeremy Lyons Apr 5 '13 at 17:20


Since you see the "bloat" that was involved. I figured I'd post this as an answer.

As I mentioned, there is definite bloat, up to 33% or more in some cases with the MIME encoding.

Increasing the limit to account for this bloat will be necessary, just don't tell your users the Exchange limit itself you configured...so if you need them to send a 10MB attachment set it to something like 16 or so.

See here as well:

Considering MIME Expansion bloat, how does that affect settings for Exchange 2003/2007/2010 message size limits?


  • Thanks for the info and links - I'll keep the 33% figure in mind. – Dave May 3 '13 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.